Got a minute? We appreciate your feedback:

Graphisoft Learn survey
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Hotlinked module - Display order

Vincent G_

I got this typical floor module that I placed on the above levels. I got one slab I can't manage to place behind the hotlinked mod. I try to send it back but I got the message saying it's as far it can go. I've tried to turn all layers on, suspend group, select the mod and bring it on the front but it didn't work. 

I assume this happens because there must be stuff in the mod that is sent back as well. Is there a solution in this case or do I have to spend an hour trying to fix the mod and re-link it? 

The mod 


The slab


I wish Graphisoft could implement a display order system the same way as material's intersection priority. You choose a number of display orders (1-10, 1-100 ...) and then define layers or/and items as per that display order value i.e every slab (or slab layer) in Display Order # 10, every floor finish D.O #15, all floor finishes tags DO#30 etc so you never have to struggle bringing stuff front and back for ever..



You are right, the display order should work like 3D documents in terms of sorting the 3D elements on plan. Unfortunately I think that may be a long way off.

Are the floor fills in your module transparent or possibly changed by Graphic Overrides. I think the default order places 2D (fills) above the model?

If you have floor finish slab(s) with a thickness in the module sitting above the unwanted slab they should obscure it?  

Can you move the slab to a new layer to isolate it? 

There is a an option Edit > Display Order > Reset... which can sometimes be useful to restore the default order of selected elements but I doubt this applies unless you want to try resetting everything...


Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)

Hi mate,

I managed to sort it out by editing the module. I re-worked the floor finishes slabs to be in the right order (not sent to back) and once published/updated it all came back to normal.
I prefer that solution rather than working with overrides as it would just be a "bad fix" creating more problems in the long run. 
Thanks for mentioning the reset button, it's indeed quite handy and often easier to just reset all and rework it from scratch.

Sam Parish

Your solution is what I would have suggested, adjust in the module to get it to work. One thing to add though, if you open the Element Information palette and look at the information pane. I believe it is on the far left, one of the values is display order level so will give you a number between 1 and 14 for the display level it is on. As you said, this is really useful for adjusting the module so you can tell everything is above level 1.

Windows 10 Pro 1909
Intel Core i7-6700; 32GB RAM; AMD RX480

@Sam Parish Could you please drop a screenshot of that info palette? 


Hi @Vincent G_ ,


It will change depending on what you have selected but here is the element information for a fill, note that I only have the very left most content tab highlighted.


Windows 10 Pro 1909
Intel Core i7-6700; 32GB RAM; AMD RX480

Awesome, so it is an actual palette I assumed it was somewhere on the element's settings. This is amazing I had no idea this feature existed, thank you, Sir, you made my day

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!