cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Publishing to DWG takes too long & creates huge files. H

Anonymous
Not applicable
I'm trying to save my archicad work in DWG format. I use Archicad's "publisher" to do this. I have about four stories to publish into dwg format. I have converted one story successfully....it converted pretty fast and the DWG file was no more than 400kb. Now, when I do the remaining 3 stories...using the same process and the same translator etc. its takes too long and I end up with DWG files larger than 35MB. Can anyone enlighten me with a solution to this problem..I would greatly appreciate this. Please take note that I have experienced the same problem in Archicad 8.1. Now I'm facing the same problem with Archicad 9.0.
13 REPLIES 13

Laszlo Nagy
Community Admin
Community Admin
One thing to check is that you might have had your Display Options set to True Weight for line thicknesses. That increases DWG/DXF size dramatically.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

TomWaltz
Participant
I find that setting Display Options for Cut fills to "Separator Only" takes all the fills out of your walls and can make a HUGE differernce if you have a lot of concrete or drywall hatch.
Tom Waltz

Aussie John
Newcomer
yes check your fills. I once though I was clever and made a wall with a curvy insulation pattern. Unfortunately it converted to many tiny lines in a DWG and the corresponding size was huge.
Cheers John
John Hyland : ARINA : www.arina.biz
User ver 4 to 12 - Jumped to v22 - so many options and settings!!!
OSX 10.15.6 [Catalina] : Archicad 22 : 15" MacBook Pro 2019
[/size]

Anonymous
Not applicable
Thank you all. Yes it did reduce the size...using any of the 3 methods all of you mentioned. My roof plan however still turns out to be 37MB. Why is this?...I use roof builder when I made my roofs..is this a factor?

Erika Epstein
Booster
Sith,
The more lines you are generating the larger the file.
What type of roof is it?
Erika
Architect, Consultant
MacBook Pro Retina, 15-inch Yosemite 2.8 GHz Intel Core i7 16 GB 1600 MHz DDR3
Mac OSX 10.11.1
AC5-18
Onuma System

"Implementing Successful Building Information Modeling"

Djordje
Ace
junior wrote:
Thank you all. Yes it did reduce the size...using any of the 3 methods all of you mentioned. My roof plan however still turns out to be 37MB. Why is this?...I use roof builder when I made my roofs..is this a factor?
Could be that all the edges of the lib parts are generated, and that you have umptillions of overlapping lines.

Try opening the same file in ArchiCAD and chech duplicates; if there are a few million, I would not be surprised.

Is there such a check for AutoCAD? Should be ...
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

Anonymous
Not applicable
Erika wrote:
Sith,
The more lines you are generating the larger the file.
What type of roof is it?
It is a spanish type roof. The thing with roof builder...it generates each tile as a 3D form. Djordje....you might be right. Its probably reading too many lines.

Aussie John
Newcomer
im guessing the 2d view is generated of the top view of the 3D of the tiling and hence all the curved parts of the tile are probably reading as many small lines. Is there an option to reduce the resolution of the tiling? or you might have to make the spanish tiles for 3D viewing only and use a fill pattern for the roof
Cheers John
John Hyland : ARINA : www.arina.biz
User ver 4 to 12 - Jumped to v22 - so many options and settings!!!
OSX 10.15.6 [Catalina] : Archicad 22 : 15" MacBook Pro 2019
[/size]

Anonymous
Not applicable
I'm afraid there are no parameters for adjusting the resolution of the 3D tiling. And I better clarify now, that the roof plan Im converting is already using a 2D fill. So, yes, I checked, and it is not the 3D tiling that the roof plan is generating..It is using the fill for roof tiles that is already in archicad. But I also discovered, that although it is not generating the 3D tiles for the roof plan, it is however, generating the 3D gutters. I don't know, my only guess is that those gutters are causing the dwg to be so huge of a file..not unless the roof fill in archicad would be a factor. Any inputs? Thanks.

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!