About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Wall connection and line pen problem

Lukas Zeleny
I´m having a problem with line thickness in AC22 and AC23. As Graphisoft changed the method of wall connecting in 2D from "axis angle" to "by material" I´m getting wrong lines at the wall corners. For better explanation please see the attached picture.
Do you have any idea how to solve it?
Laszlo Nagy
Community Admin
Community Admin
This is an issue currently with Composite Structure Walls. The best thing I can recommend is to model the Corner with a Complex Profile Column. In the Complex Profile Manager you will be able to set the Pen of each edge, and even hide edges, where needed.
Then you can Classify the Column as "Wall" so it will schedule properly.

By the way, if your Wall has a single skin, why don't you use a Basic Wall, why do you model it as a Composite Structure Wall?
Get Archicad Tips at
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, Ac20-Ac27
Loving Archicad since 1995
Lukas Zeleny
thank you for your recomandation, will try it. It will be time consuming ind buildings with many different angles and wall materials, it can be only temporary solutions until its fixed in Archicad.

The reason for use of composite walls is that we need one line of the wall thick and another thin.
I agree this shouldn't be happening, but there is an easier workaround avoiding columns and simply requiring the creation of a duplicate composite wall type with different wall end pen settings.

Your current composite is using a heavy pen of the outside face for the wall end lines, the duplicate should use the lighter pen as used for the inside face. By changing the wall types things should turn out as expected, but depending on priorities and other aspects e.g. openings you may need to split a wall and change the wall type for the corner.
Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)
Lukas Zeleny
Thank you DGSketcher. Your solution is easier than using columns.

Still, it creates unnecessary entry in composites, its getting crowded there More attributes = slower project and slower designing.

Has there been a solution found to this problem with the latest versions? Because I think I have the exact same one

Make sure the end lines are on in the composite settings and the pen matches the pen of the side lines.


If you have two different pens for the side lines as in the first post, then the only way I know to automate this is to split one skin into two skins (half thickness each).

This allows you to have a different end line pen for each skin - again that matches the side (skin) line for each skin.




The only downside is the free end of a wall if it is not joining something else.

There will be 2 pens at the end.

Not really a problem if the side skin lines are different as it is just highlighting the different sides of the wall.


If the side line pens are the same (as in your case by the looks) then there is no need to split one skin into two.

Just make the end line pen the same (and turn it on).


But you can also make one skin thin and the other wider (equal to the original one skin) to give the illusion of a single line at the end.






One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!