Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Archicad 20 not starting-up

Not applicable
Good afternoon everyone,

I've been running into a big problem regarding booting Archicad. My desktop pc isn't able to boot up archicad further then the first window (screenshot is added) anymore. It did however run fine a couple of months ago. My laptop is running it fine.

Already tried reïnstalling it, trying a different version of java and a different version of Codemeter. Kind off running out of options on what to do.

Has anyone else encountered this problem before, and if so, knows a fix to this very frustrating problem.

Specs of the pc I'm running it on (not sure if they matter)
MOBO: Asus b350
CPU: Ryzen 5 1600
RAM: Hyperx 16gb 3200mhz (running a bit lower)
GPU: Gigabyte gtx1080
SSD1: Samsung 860 500gb
SSD2: Samsung 860 250gb
HDD1: Seagate 2TB


Erwin Edel
Try contacting your reseller, they will most likely be able to offer you support in fixing this.
Erwin Edel, Project Lead, Leloup Architecten

Windows 10 Pro
Adobe Design Premium CS5

Not applicable
this is not serious at all, answers like that i mean

i have the same problem on 21 and 19, initial window opens up and then freezes for more than 5-10 mins

this is some java problem, but i have tried almost everything i can think of

does anyone in this forum even answer a question

i mean i read it a lot, and this query comes up at least 10 times and no one from the company or users is not able to answer how the hell a steady running program starts to take 10 mins to load instead of 10 secs ?

come on ppl

Eduardo Rolon

In this case contacting your reseller is the correct answer.

AC-Talk is a User forum and it is not an official support channel. Though GS monitor the forums they don't necessarily answer posts. AC20 is a 2 year old version and there might be multiple reasons that are specific to this case from a dying HardDisk to a driver problem so if nobody has a specific solution to the same problem there might not be an answer. Also in this case the problem was on a specific computer since "cdebree" indicated that it ran fine on his/her other one.

Anyway the original post is almost a month old so I could guess that cdebree found his answer and forgot to update it here.
Eduardo Rolón AIA NCARB
AC26 US/INT -> AC08

Macbook Pro M1 Max 64GB ram, OS X 10.XX latest
another Moderator

Erwin Edel
In my experience if ArchiCAD is acting up in very strange ways, your best bet is to contact support. Trying to work it out yourself or with the help of the userbase here, will result in many many hours time lost.

I am not familiar with how things work in other regions, but we have a paid subscription and that comes with free support from our reseller. So I call them if I run into problems and they in turn are my link to Graphisoft support if things are too complicated for them to fix for me.

Without wanting to accuse anyone posting on this topic so far: but if someone can't contact support for help, I suspect they did not acquire ArchiCAD through the ussual channels, so to speak.

If someone asks for tips with working in ArchiCAD, I'm more than happy to help, when I can find time to reply.
Erwin Edel, Project Lead, Leloup Architecten

Windows 10 Pro
Adobe Design Premium CS5

Not applicable
Support was not able to help. ArchiCAD is acquired through the usual channels, so to speak. PC is brand new AIO 1 week old, so no hard disk problems there. But in general ArchiCAD being an awesome software for drawing has some strange dependencies, which are unnecessary. I guess they are also different types of people, if one can wait for the electricity company to come change a bulb, this is not my case. I spent quite a lot of time after work and found an answer. It was unexpected, and once again proves strange dependencies of the software, which in my opinion have a 1% chance of being found if the computer is not brand new, because I was able to scan one by one some issues. I am an architect, and not a IT specialist, but in the 21st century, programming, computing and architecture, especially parametric one cannot be done without extra knowledge. If you have a fire, but it dies out, do you always call on Prometheus to light it up ?

I will describe the answer I found in a bit.

Not applicable
This is an issue for us as well on AC21.
Contacting the lokal reseller support has resulted in me answering the same question three times, but still they ask questions not related to the specific issue.

You start Archicad and it freezes when it gets to the splash-screen. And there it stays.
I do not think that the lokal reseller support know the answer to such questions. We are VIP-customers, but frankly VIP-customer for Graphisoft seems to mean a totally different thing to them then the rest of the world.

So what Graphisoft should do is to get someone with deep technical knowledge on this forum in order to actually help their customers instead of waisting their time.

Not applicable
I know this thread is old, but this issue is still ongoing.

1 computer in our office is experiencing this issue. They can open the first instance of Archicad 22 (also happens with 21 and 23) but the second instance hangs at the splash screen indefinitely.

Graphisoft support tried to help, but eventually got no where and told us to buy a new computer.

We also wiped the computer, reinstalled windows 10, and installed only archicad. It still had the same problem.

The computer is a surface pro 4. It's the only one we have in the office.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!