Got a minute? We appreciate your feedback:

Graphisoft Learn survey
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

C drive file bloat with point cloud

Not applicable
I have found that I keep getting PointCloudTempFi files duplicate in the local appdata file. This can be in excess of 100GB. What are these files doing and why are they duplicating?

This bloat drastically effects my machines ability to run ARACHICAD to the point where loading into teamworks (BIMcloud basic) in archicad 24 takes several hours.

I am the only one in the team that gets this. The only reason I can see is that I imported a point cloud to the teamworks file but this was months ago and the point cloud has been converted to gsm objects.

Image is after a clear out.

Hello tlodge,

Your point cloud is not converted into a gsm but into a database called by a object.
If you open the gsm you will se a POINTCLOUD command into the 3D script.
GraphiSoft Point Cloud is a translation about your xyz or e57 file which is lighter than the original file.
The GSM call a GSPC file

You are able to put these files into your embedded library but GSPC are quite heavy files.
Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 26 FRA FULL

OS 11.6 Big Sur - MacBook Pro 2015 - 16Go RAM
"Quality is never an accident ; it's always the result of an intelligent effort" John Ruskin

Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni

Thank you for reporting this issue and I am very sorry about the experience!

This is intentional to have these temp files here. These temp files are working as a "cache" - they are created every time you place a point cloud into a plan, in order to work faster with the huge point cloud file. When you close all running Archicad instances which contain point clouds, the files should be deleted. I think the problem here is Archicad was crashed due to low memory before it can delete these temp files normally.

There is an option to disable these temp files, but the point cloud will be loaded directly on RAM. It requires at least 32GB of RAM if you work with large point cloud file frequently. It can be activated via registry:
  • Close all running Archicad and check if all the temp files have been disappeared
  • Navigate to HKEY_CURRENT_USER\SOFTWARE\Graphisoft\ARCHICAD\ARCHICAD xx...\PointCloud\FilemappingEnabled, and change this key to 0
  • Thank you for your understanding! I hope this has answered your question. If you have any further issues, feel free to ask me again!

    Best regards,

    Minh Nguyen
    Technical Support Engineer

    Any solution for mac users?


    The setting is here:

    /Users/....Username...../Library/Preferences/com.graphisoft.AC 25.0.0 GER v1.plist











    ARCHICAD since 4.55 | macOS current | AC 26 current

    Still looking?

    Browse more topics

    Back to forum

    See latest solutions

    Accepted solutions

    Start a new discussion!