Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.
SOLVED!

Hard Crash at Page Setup. Apple Silicon v26.

Robert Nichols
Advocate

Is anyone else seeing hard crashes upon selecting the Page Setup menu item on M1 chip? I'm running current v26 on Mac Studio with macOS 13.0.1.

 

Bug report is submitted. It's nasty! 

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13
1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Robert Nichols
Advocate

Hi, Melissa. 

 

Graphisoft, just a few days ago, provided me with a workaround, which is suitable because I think the problem is just with the print/page settings of a few files. Once the workaround has been applied to the troublesome files, then you should be fine. At least that's how it's gone for me with 3 out of, maybe, 8 files (haven't tackled the others yet).  If you have a reliable list of the files that are giving you trouble, you can take advantage and fixe them in a "wholesale" fashion, saving some time. You need to be moderately fluent in working with the Terminal app. Here is what they sent, and what has worked for me:

 

Workaround:

  1. Find the .plist file for your Archicad version. In a Terminal window execute the following command:

ls -1 ~/Library/Preferences/com.graphisoft.AC*.plist
This should result in a list like this:
/Users/jmihalicza/Library/Preferences/com.graphisoft.AC 26.0.0 FRA RC1.plist
/Users/jmihalicza/Library/Preferences/com.graphisoft.AC 26.0.0 INT v1.plist
/Users/jmihalicza/Library/Preferences/com.graphisoft.AC-ARM 26.0.0 USA v1.plist
Every installed Archicad version has a corresponding plist file. Copy the full path corresponding to your Archicad version you experience the issue with.
2. Add the necessary setting to enable print settings discarding with the command below. Make sure the plist file path is replaced with the one identified in step 1:
/usr/libexec/PlistBuddy -c "set ':PrintPlot:Discard Print Settings' 4" "plist-file-from-step-1"
For example:
/usr/libexec/PlistBuddy -c "set ':PrintPlot:Discard Print Settings' 4" "/Users/jmihalicza/Library/Preferences/com.graphisoft.AC-ARM 26.0.0 USA v1.plist"
3. Launch Archicad.
4. Open the plan file that crashes AC at Page Setup.
5. Open Page Setup. We believe it should not crash with the above setting.
6. Save plan file.
7. Exit Archicad.
8. Repeat steps 3-7 for every plan file that produces the issue.
9. Disable print settings discarding, same as step 2, but the value is 0 instead of 4:
/usr/libexec/PlistBuddy -c "set ':PrintPlot:Discard Print Settings' 0" "plist-file-from-step-1"
For example:
/usr/libexec/PlistBuddy -c "set ':PrintPlot:Discard Print Settings' 0" "/Users/jmihalicza/Library/Preferences/com.graphisoft.AC-ARM 26.0.0 USA v1.plist"
 

 

 

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13

View solution in original post

30 REPLIES 30

I haven’t noticed this. Could it be that the print driver needs updating? 

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 27.2.1
macOS Sonoma (14.5)
Robert Nichols
Advocate

Something like that, Lee. In any event it's fixed now. More likely related to printer rather than Archicad or macOS. Thanks for responding.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13

Robert, how did you fix the issue? Just got a mac studio and can't get v26 to launch at all (keeps crashing)

Hi, Arqtect.

 

I fixed my situation by downloading a fresh printer driver from Brother, but it sounds like you are having a different, more fundamental, problem. I would ask if you are sure you have the Apple Silicon version of v26 on your Mac Studio, but I doubt the installer would have worked if there was a problem with that. If the crash is immediate upon starting Archicad, I would suspect something to do with the licensing components. 

Go here: https://Graphisoft.com/downloads/protection_key and download and reinstall the Codemeter driver. Someone else helped me find that last week, and it worked.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13

Thanks,  I will give that a try. I will likely end up contacting Graphisoft support for help

Thomas Holm
Booster

I get the same crash when selecting Page Setup in Archicad 24 on a 2019 MacBookPro (intel). I've updated to Ventura 13.1.

AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1

At first I let the OS prepare my printer setup (new computer, so much to set up). That's when I got the crash. Following advice of someone here, I went to Brother (printer manuf) site and downloaded a printer driver from there (which happened to be AirPrint in this case - I guess proper networked driver for Ventura not ready yet) and the crash went away.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13
nbrauer718
Contributor

I'm having the same problem, but only with one file.  Page setup causes a crash in all views.

 

Interesting. All files make it crash for you? In my case, it's not all files. I'm on a newly acquired and set up machine, and I suspect files that had one particular setting on the old machine are choking the new. At least that's the impression I have (actually have no useful knowledge about the insides of computers).

 

Thanks for weighing in. Hope your situation improves. I sent Graphisoft all the diagnostic info they requested, so hopefully something will happen.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13