Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Installing Archicad 9 on Intel Mac

Not applicable
Hello all,
I know this topic has been covered a bit but I havn't found a clear answer. I am trying to install ArchiCAD 9 on my Mac OS 10.6 (SnowLeopard). I know it is possible to do running in emulation mode through Rosetta, in fact I did it about two years ago and have been running ArchiCAD without any problems. Unfortunately I had to wipe my hard drive last week, and now have to figure out the install process again. I understand some people have installed the program on a PowerPC Mac and copied the folder over, successfully. I however have no access to a PowerPC Mac and need to figure out the Rosetta emulation mode (again). This isn't good... Does anyone have any suggestions or step by step instructions? I've downloaded the WIBU drivers, file converter, etc. When I go to make the install, I get to the install location and it tells me to "specify a directory name."

Another method I tried to install by is from the Archicad on my external (backup) hard drive. I tried copying from the ext hard drive, onto my laptop and got the following error: Application Launch Failure: The application "ArchiCAD" could not be launched because of a shared library error: "<ArchiCAD><ArchiCAD><GSCppRuntimeLib><>". Yeah, whatever that all means.
Karl Ottenstein
Don't really understand what isn't working... what happens when you DO specify a directory name?

Are you sure that after wiping your disk and re-installing 10.6 (and you did install all updates, right?) - that you do not have Rosetta? If so, see this article on where to find it / how to install:

You can also try downloading the AC 9 USA "converter package" here:

which should be a ready-to-run installation, just copy into your Applications folder. It will not have the full US library, but you should be able to get it from your AC 9 installation disk or a backup. (For that matter, if you had a backup of your old disk, just restore the Applications > AC 9 folder from there.)

Looks like the library is also here:
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB