BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Keyboard shortcuts failure

Anonymous
Not applicable
The following bug shows up repeatedly with any version of ArchiCAD. No matter how many times I re-start the program, sometimes the keyboard shortcuts do not function. In this particular case, I have been trying to drag the element by pressing CTRL + D and then CTRL again to copy it but the CUT option appears any time I press the CTRL key. Please let me know I can fix this issue. Thank you!
6 REPLIES 6
vistasp
Advisor
Welcome to this forum anto_bg. Do you, by any chance, have sticky keys turned on?

Provided you haven't changed the default ARCHICAD shortcuts, a quicker way to drag a copy would be to use Ctrl+Shift+D.
= v i s t a s p =
bT Square Peg
https://archicadstuff.blogspot.com
https://www.btsquarepeg.com
| AC 9-27 INT | Win11 | Ryzen 5700 | 32 GB | RTX 3050 |
David Collins
Advocate
Switching keyboard languages from English to Cryllic will kill the shortcuts.
I've also recently had this problem from time to time when I switch the keyboard language from English to Greek and then back to English. I think its a Windows 10 issue. I haven't figured out how to fix that yet.
David Collins

Win10 64bit Intel i7 6700 3.40 Ghz, 32 Gb RAM, GeForce RTX 3070
AC 27.0 (4001 INT FULL)
Anonymous
Not applicable
Thank you both for your suggestions!
I think the root of the problem are the keyboard languages. I was switching constantly between English and Cyrillic. It's an ongoing issue. It used to happen with the older versions of Windows as well.
Anonymous
Not applicable
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
Anonymous
Not applicable
Hello my friends. I have the same problem but unfortunately in the archicad 21 registry i cannot find the specific KeyMode Shortcuts registry key. any ideas?
Laszlo Nagy
Community Admin
Community Admin
It is there in my AC21 INT version, as you can see it in the screenshot.
If it is not there for you, you can try to create it. You will have to right-click on the right side, and use the "New > DWORD (32-bit) Value" command to create the value and give it the name "KeyMode Shortcuts".
I think after doing this an quitting the Registry Editor, you will have to restart ARCHICAD.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Learn and get certified!