Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Problem with decimals, only accepts full numbers

Not applicable
Hello everyone!

I'm having some trouble in ArchiCAD 18. I'm working in a new laptop and it's the only computer where it happens, and it happens in all the files.

Archicad doesn't accept decimals. If I move 1,50m it will only move 1,00m, or if I place 0,75m it won't move. The numers appear in the input as they are written but ArchiCad doesn't allow the value. I am working in milimeters now, as I can't work in meters, and though it's workable, the same problem happens if I change the size of a font. I can only have fonts with 1,0mm or 2,0mm.

This is very odd and seems to be a bug, as we all here in the office tried everything and no one seemed to find an answer for this. I have reinstalled it and it stayed the same.

Has anyone had the same problem, and how did they worked it out?

Thank you all in advanced for your help!
Laszlo Nagy
Community Admin
Community Admin
Could this be that in your operating system the decimal character was changed from "," to some other character (e.g. to the "." character) and this is causing the problem?

You should enter your specs like computer, RAM, OS, AC version into your signature in your Profile page so we can better help you. Right now I don't even know whether you are on Windows or Mac.
Get Archicad Tips at
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, Ac20-Ac27
Loving Archicad since 1995
Not applicable
Hello laszlonagy! Thank you!

I write the comma, even if using the dot in the numeric keyboard, it turns automatically into the comma and appears in the input as it should. Only after pressing the enter key to confirm the value that it only assumes the value before the comma.

The laptop is a Toshiba Tecra W50-A-117, Intel® Core™ i7-4810MQ vPro, 32GB RAM, SSD, NVIDIA® Quadro® K2100M using Win7 64bit with ArchiCAD 18 5100. There is no 6000 in PT and the 19 is not yet available...
Not applicable
Done... Changed the comma for points in windows configuration and it now works fine. I can work in meters again... This is why I love Mac OS X so much!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!