Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
About Archicad's design tools, element connections, modeling concepts, etc.

Grasshopper – Archicad Live Connection not working on M1 iMac


I am using Rhino7 and Archicad25 on M1 iMac. After Start Connection, the connection status is green and there is no error information shown in Grasshopper, but no models are generated in Rhino or Archicad, and the material or favorites pop-up window could be not loaded.


However, everything is fine on my older 2015 Macbook. Is there a compatibility problem for Live Connection with M1 Mac?


Hi @Jaime-airc_digital and @Alois Rosenfeld 


Thank you very much for sharing the report! I checked both crashes and they are identical. Thanks to Jaime's comment (deconstruct a morph), I was able to reproduce the crash, but the strange part is the crash modules in my case are totally different from yours. I have entered defect DEF-10281, however I strongly suggest reaching out to your local support for further investigation, as they will be able to contact our developers for confirmation of the problems.


Thank you once again for your finding, and I am very sorry for the issue!
Best regards,


Minh Nguyen
Technical Support Engineer

HI @Minh Nguyen ,

Thank you very much for your answer. 
As mentioned above, I already made everything I could do to communicate this issue to local support. But they are categoric: They can't do nothing on their side, and I should directly ask Graphisoft to investigate further.
Please, I already mentioned this issue to local resellers (IDC & Abvent) 7 months ago, and nothing improved. They only told me that I should hope that with Archicad 26, it should be fixed again, which is not satisfactory as an answer.
I am available if you want to have a direct chat about it. 
I really hope that the defect DEF-10281 will be investigated by the Graphisoft team directly.

Best regards,



Does anyone know why this error happens on Mac?
What happens is that I need to use rhino-grasshopper and make the live connection with Archicad 25-26, I download and install the live connection plug-in and when doing something in grasshopper it is not reflected in Archicad, however, Archicad does recognize that there is a connection. I have already tried to test different versions and I have also installed the live connection plug in for each version they all have the same error.

In a post on this forum, I found that a possible solution was to modify the name of the file found inside the path /Users//Library/Preferences/) and rename it from:

com.mcneel.rhinoceros.7.plist to com.mcneel.rhinoceros.plist

But this didn’t work. Below are some images of what happens. I thank you in advance for your help.


Captura de Pantalla 2022-10-20 a la(s) 4.54.30 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.51.10 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.52.39 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.52.26 p. m..png

I used to experience this problem, but it got sorted with the latest update of the connection. Have you tried that? I am in MacOS Monterrey and using AC 26, not sure if being in Big Sur may be a factor on your issue.

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.

Yeah. I tried to install and uninstall different versions of Archicad (24,25,26), also I install and unstall the connection with rhino-grasshopper for rhino (7,6) depending on the connection that exists for each version as stipulated in Graphisoft but the error continues as seen in the images.


This some videos with the problem:

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!