About Archicad's design tools, element connections, modeling concepts, etc.

Repeatable cursor bug in Archicad 26-5002, Mac 12.6.3, Intel MacBook Pro

Chris Hough

So I am noticing that the feedback on the cursor disappears in Archicad 26 after I change some of the parameters in the info bar. So for example, I change the width, or the height of an object by clicking on the info bar parameters box, then when I go back to the 2D window, my cursor feedback (the ability to see dynamically how I am moving an object, or how long it will be, or the ability to snap to another object) is disabled/ missing. If I click on the info box window (or out of the 2D window), this interactivity comes back.
Not sure if this has been documented previously or not (or where in the new forum structure to place this), but I could not find anything on this after a quick search.


Some system specifics:
Archicad 26 Build 5002

macOS 12.6.3
MacBook Pro 16" 2019 (Intel i9)

Sonnet eGPU running an AMD Radeon 6800XT

Screen Shot 2023-06-06 at 1.30.20 PM.jpg

Screen Shot 2023-06-06 at 1.30.36 PM.jpg

Screen Shot 2023-06-06 at 1.32.18 PM.jpg

Owner, Heritage Design Studio
AC 4.5-26
Maco OS Monterey | 2.4 Ghz i9 | 32Gb | AMD RX 6800 XT


Simliar issue here. I'm on 12.6.6 and for some time now (it wasn't always like this!) I can observe the same problem. For me the only way to bring functionality back is back by tabbing out of Archicad and back in. Very tiresome.

Lucas Becker | Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Karl Ottenstein

I'm wondering why you're running 12.6.3 when 12.6.6 is the most recent release of Monterey?


I cannot reproduce this behavior with AC 26 Build 5003 Apple Silicon or the Intel version Build 5002 on Ventura 13.4.


I could see some strange flashing of the dragged object on and off with AC 25 Build 7000 on Ventura 13.4 which might be related to what you guys are seeing.


Since you both see it on Monterey, I'll report this to technical support with a link to this thread.  If anyone else sees this behavior, please post your macOS version and AC build info along with steps for reproduction if they differ from what @Chris Hough said.  Thanks.


One of the forum moderators
AC 26 USA and earlier   •   macOS Ventura 13.6, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Yeah, so I’m on 12.6.3 because auto update wants me to go OS 13 now, which I am

not 100% sure is working with both Archicad and Twinmotion- maybe it is and I should just upgrade, but that means stopping for an hour to do that or setting it up to update overnight and I’m already juggling 20 things at once, thank you very much.. I suppose I could go hunt 12.6.6 down and force the update, but as they guy with 12.6.6 is reporting the same issue, I’m thinking that’s not really a solution, and honestly I’m not the guy to jump on every friggin update that comes out and rush to install it. But thanks for the question- there’s your answer. Ain’t nobody got time for that (specially if it don’t fix nuthin!).

Owner, Heritage Design Studio
AC 4.5-26
Maco OS Monterey | 2.4 Ghz i9 | 32Gb | AMD RX 6800 XT

Totally understand what you're saying!   Yeah, I wouldn't expect 12.6.6 to fix the issue - since runxel has it as well.  It's just that just like every new build/update/hotfix of Archicad contains huge numbers of bug fixes (and may sometimes introduce a new one or two) ... every point update to macOS has bug fixes and security updates to prevent malware from using known weaknesses in the OS that are fixed in the update.


(Moving from OS 12 to OS 13 is an upgrade vs update in Apple lingo.  Typically macOS upgrades are not particularly stable when first released each fall - to say nothing of Archicad typically not working with the initial release - and so for upgrades it is wise to wait for the first point update of the new OS.  Ditto all too often with Archicad... it is usually safest to wait for the first hotfix/update before switching to the new release.)

One of the forum moderators
AC 26 USA and earlier   •   macOS Ventura 13.6, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Chris, agree that macOS 12.6.6 may not fix things for you, but you can typically update without upgrading macOS... there should be a line reading 'Additional updates are available...' (or similar), click on the blue writing in the same line and you should see the point updates to 12.6.6


Hope that helps.

Design Technology Managers.
All  on macOS | since AC 6

Archicad Framework > Smart Template 26
Smart Tree, Transmittal and Universal Label and other smart GDL Objects
By Architects for Architects.

Oleksandra Vakariuk

Dear @Chris Hough,


Thank you for raising this issue!

I tried to reproduce this on Monterey with an Intel processor based on your screenshots. What I experienced is that I cannot change any of the parameters in the Info Box while element editing is activated (e.g. I select Move function but don't move the Element yet). Instead, I experience the characteristic OS sound that lets me know that I'm not allowed to do that, so I get stuck at Step 2.

I'm wondering if a screen recording of the issue can help to reproduce it in-house. May I ask you to send one? Thank you in advance!


Kind Regards,

Oleksandra Vakariuk

Technical Support Engineer

Chris Hough

I'll generate a video for you in the near future- I run into this issue several times a day. I just need to find some spare time to record it for you is all... expect it within a week or so.

Owner, Heritage Design Studio
AC 4.5-26
Maco OS Monterey | 2.4 Ghz i9 | 32Gb | AMD RX 6800 XT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!