BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

v15 3D Connexion Space Navigator button not working

Anonymous
Not applicable
Hi,

I have been using v13 for quite some time and am only now getting onto v15. I am a faithful user of the 3DConnextion SpaceNavigator mouse, and I use it extensively in the 3D window. I have one of the two buttons programmed as a "Shift" button, and I use this to quickly select objects in the 3D window to manipulate them.

My problem is, in v15 the SpaceNavigator Shift button no longer works! It works fine in v13... And oddly, in v15 I can program the button to be other things, and they work fine as well... I do have the latest drivers for the mouse. If anyone is having a similar issue or has a workaround, I would appreciate it!

Thanks,
Foster
4 REPLIES 4
Tamas Eros
Graphisoft Alumni
Graphisoft Alumni
Dear Mr. Foster,

I could test the 3D Connexion Space Navigator (with driver 3.15.3.) mouse on Win XP with ArchiCAD 15 and I was able to set one of the buttons as 'Shift' button. Then it worked fine in 3D window for selecting elements.
Please try the following: while ArchiCAD is running open 3Dconnexion Properties then on Button Configuration tab you should be able to select ArchiCAD application. (Select the one with your user name if there are more.) Then select Shift Key for the desired button like on my screenshot.
I do not know if it matters, but the 3D Connexion driver was installed after ArchiCAD.
Hope this will help.
Kind regards,
3dConnexion02.JPG
Tamas Eros
Technical Support Engineer
GRAPHISOFT
Follow us on Twitter
GRAPHISOFT HelpCenter - the ArchiCAD knowledge base
Anonymous
Not applicable
Hi,

Thank you for your reply. I realized that my signature was incorrect. I am not longer using XP. I now have Windows 7 64 bit.

I did all of your suggestions with no result. I also contacted support at 3D Connexion, and I did a complete fresh re-install of the mouse driver. Again, with no result.

I can easily program the mouse buttons to do other functions in ArchiCAD, they all seem to work. EXCEPT for the "Shift" key. I have tried to set this both the "normal" way and also creating a "custom" function, and neither work. I also tried the shift key with a second 3D mouse (from my home), and it would not work either...

Can you please check this again with Windows 7 64 bit and the latest mouse driver and ArchiCAD 15? Since I have tried with 2 seperate 3D mice with no result, it seems to be a programming error.

Is it possible that I may have switched some function off in the Work Environment options? In the 3D window, using the keyboard shift key works fine, just not with the 3D mouse.

Thank you for your time,
John
Tamas Eros
Graphisoft Alumni
Graphisoft Alumni
Hi,

I have tried the 3D mouse on Win 7 64 bit with ArchiCAD 15 but it worked for me as expected. I could set one of the buttons to work as Shift button and could use it in ArchiCAD the same way as I explained before.
I have installed the latest 3.15.5 driver after ArchiCAD was installed.
Please check the following: in ArchiCAD do you have the 3Dconnexion menu item available from the View/3D Navigation Extras menu? Then if the 3Dconnexion Enabler file is present in the following folder: Program Files/Graphisoft/ArchiCAD 15/Add-Ons/Standard/. If not probably your ArchiCAD is not installed correctly.
Regards,
Tamas
Tamas Eros
Technical Support Engineer
GRAPHISOFT
Follow us on Twitter
GRAPHISOFT HelpCenter - the ArchiCAD knowledge base
Anonymous
Not applicable
Thanks for your reply and efforts,

Yes, I do have the 3DConnexion menu item available, and yes, I also do have the 3DConnexion enabler file...

From a troubleshooting standpoint, I have tried 2 mice and fresh installs of mouse drivers. We have also now verified that the 2 items above are correctly installed in ArchiCAD. It seems that it is now time for me to try a fresh install of ArchiCAD...

I will keep you posted, thanks again for your help.

John
Learn and get certified!