Choose your top Archicad wishes!

Read more
Parametric design
About Rhino & Grasshopper and PARAM-O.



Does anyone know why this error happens on Mac?

What happens is that I need to use rhino-grasshopper and make the live connection with Archicad 25-26, I download and install the live connection plug-in and when doing something in grasshopper it is not reflected in Archicad, however, Archicad does recognize that there is a connection. I have already tried to test different versions and I have also installed the live connection plug in for each version they all have the same error.


In a post on this forum, I found that a possible solution was to modify the name of the file found inside the path /Users//Library/Preferences/) and rename it from:

com.mcneel.rhinoceros.7.plist to com.mcneel.rhinoceros.plist


But this didn’t work. Below are some images of what happens. I thank you in advance for your help.


Captura de Pantalla 2022-10-20 a la(s) 4.54.30 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.51.10 p. m..pngCaptura de Pantalla 2022-10-20 a la(s) 4.52.39 p. m..png


Which version of Archicad are you using? 

If it is AC25 version 5010 and above you will need to run the Archicad installer again after running the Grasshopper installer.  The Grasshopper installer needs to be updated to match the current release of the AC version you are using.  I am about to start using AC/Grasshopper connection for 26 so the process I will be doing is uninstalling the AC25 /Grasshopper connection using the uninstall program found in ~/Graphisoft/Uninstall.GC/Uninstall.App.  Then I will run the AC26 Grasshopper connection installer and then run the current release of AC 26 version 4019 (or later if people read this later than the 25/10/2022).  


Then you need to ensure that you have given full disk permission to the following folders:


~/Applications/Graphisoft/Archicad 26/Add-Ons/Grasshopper-Archicad Live Connection





~/Applications/Graphisoft/License Manager Tool/Graphisoft License Manager

~/Applications/Graphisoft/Archicad 26/Archicad


~/Users/(Yourloginname)/Library/Application Support/McNeel


For Australian and NZ users who use CadImage Tools:


~/Users/Shared/Cadimage Tools


For AC25 rename the .plist file at the following location:

~/Users/(Yourloginname)/Library/Preferences/com.mcneel.rhinoceros.7.plist and rename to com.mcneel.rhinoceros.plist


I hope this gets you up and running.  I am sending you a private message with my contact details incase you run into problems.

Kind Regards,

Sebastian Monroe


T: +61 3 9017 6666


Archicad v26, Mac Mini INTEL 64GB, AMD Radeon Pro
Eleazar Coello

Hi! I have the same problem, it shows nothing on AC26 SPA 3001, using a MacBook Pro M1. I was able to install the AC-GH Live Connection for AC 26 3001 the connection between programs it's fine but it's not working, the meshes i get is only visible on Rhino windows and not in AC.


I did reinstall so many times, it's so frustrating 😑


Also, i tried with the AC 26 3001 INT version and the AC 25 3011 INT and it still didn't work either.


I tried all of that Sebastian wrote but the problem remains.




Archicad 26 MacBook Pro M1 2020

Captura de Pantalla 2022-10-31 a la(s) 5.14.58 p. m..pngCaptura de Pantalla 2022-10-31 a la(s) 5.16.44 p. m..pngCaptura de Pantalla 2022-10-31 a la(s) 5.16.37 p. m..pngCaptura de Pantalla 2022-10-31 a la(s) 5.16.27 p. m..png

G'day mate,

Have you tried to upgrade to the latest builds of both Archicad and Grasshopper.  I also did a complete zero of my hard drive to remove any latent or unlinked files that might have accumulated from using Rhino.  Make sure that when you upgrade Archicad and the Archicad Grasshopper link that you do it in build number order.  For the Australian installers for example I did the following:


AC26 AUS Build 3010 Then Rhino.  Then AC GH Build 4007 Installer.  Then the AC26 AUS Build 4019.  


My install seems to be working okay at the moment.  Are you able to post your GH file and I will see if the error reproduces at my end?

Kind Regards,

Sebastian Monroe


T: +61 3 9017 6666


Archicad v26, Mac Mini INTEL 64GB, AMD Radeon Pro

Hi Sebastian, thanks for the tips, i will try to upgrade in order like you say, meanwhile here's my GH document, i don't think it's a problem with the GH document.

Hello Sebastian I have the same problem once that I have installed the apple sillicon's archicad 26 I have downloaded the add on for the connection but at the moment to start working nothings happen if I choose a column for example and in GH try to set the column in archicad nothing happen, can you help me with this ?

Hello Sebastian, i Wonder if you have found any solution for this problem i am using a mac m1 with AC 26 apple sillicon and rhino 7 and still not working, if you know any sollution I hope you can help me