cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ARCHICAD File Browser dialog keeps freezing on macOS 10.14 Mojave

Daniel Kovacs
Graphisoft Alumni
Graphisoft Alumni

Affected version(s): All | Severity: solved | ID: 258172

Issue

When selecting an option in ARCHICAD that opens a file browser dialog (e.g. Open, Save As, Place Drawing, etc.), you might notice 5-10 sec delays when trying to navigate. The beach ball cursor may not appear, only ARCHICAD will be unresponsive for a few seconds.

wp-content_uploads_2019_01_dialog-freeze.gif

Workaround

We have found that if you go to 'System Preferences App>Security & Privacy>Privacy', and Untick the ARCHICAD option in all the sub menus from the left, then the problem goes away. Please also make sure that you are on the latest update of ARCHICAD.

wp-content_uploads_2019_01_Untick-ARCHICAD-1024x899.png

If the above solution doesn't work for you, please contact your local Support team, and tell them about your issue, referencing this article.

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!