cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Antialiasing disabled on Intel GPU Macs with 4K resolution

Csaba_Kezer
Graphisoft Alumni
Graphisoft Alumni
Affected version(s): ARCHICAD 19, 20, 21, 22| Severity: workaround applicable | ID: 208529
 
Multisample anti-aliasing (MSAA for short) is a technique used in computer graphics to improve image quality. This technique samples multiple locations within every pixel, and each of those samples is fully rendered and combined with the others to produce the pixel that is ultimately displayed. As a result, slanted lines appear smoother on the screen giving a better image quality. MSAA is built into ARCHICAD (referred simply as Antialiasing on the interface) to achieve the best image quality at all times:
wp-content_uploads_2017_05_antialiasing-on-off.png
An image displayed with Antialiasing however requires multiple times more resources of the Graphics Processing Unit (GPU) than without Antialiasing. This is why it can cause performance issues on hardware that are not equipped with a professional GPU, but drive a large resolution display. As an example, the newer 21,5" iMacs with 4K  display (4096 x 2160) are not equipped with a dedicated GPU, but only an Intel HD or Intel Iris Pro unit, that are not sufficient for antialiasing images on the 4K resolution screen. To avoid performance problems, Antialiasing on such machines is turned off in ARCHICAD 20 and newer. In the work environment, you will be prompted with Warning: Antialiased drawing has been automatically disabled due to insufficient video card resources.
wp-content_uploads_2017_05_Screen-Shot-2017-05-05-at-10.12.08.png

On ARCHICAD 22:

On macOS Sierra and El Capitan (if a 4K display is connected) ARCHICAD 22 might crash because of how macOS handles the dedicated and integrated GPU (causes memory leaks). To avoid this, ARCHICAD needs to disable Antialiasing, even though the dedicated GPU would be sufficient for it. In this case we don’t recommend the force start of the MSAA, the solution is to update the system to High Sierra.

On ARCHICAD 21 and earlier:

On Macs with High Resolution Displays (e.g. 21,5″ iMacs with 4K), it is possible (but not recommended by GRAPHISOFT) to turn Antialiasing back through the macOS Preferences file of ARCHICAD. To do so follow the steps below:
  • in Finder select Go menu
  • press and hold the alt (option) key to make Library visible in the Go menu
  • select Library and navigate to: ~/Library/Preferences/com.graphisoft.AC-64 20.0.0 INT v1.plist (note that your plist file name might differ depending on your AC version & language version)
  • Open the selected .plist file with a plist editor application (e.g.: PlistEdit Pro, Pref Setter, Xcode)
  • Navigate to the OpenGL folder and select the Antialiasing Mode key
  • Change the value to 1 to force ARCHICAD to use Antialiasing with your Intel GPU
  • The change takes effect only after ARCHICAD is restarted
wp-content_uploads_2017_05_antialiasing-mode-plist-preferences.png

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!