cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Convert CodeMeter Hardware key to HID

Gabor Almasi
Graphisoft
Graphisoft

CodeMeter hardware license keys shipped by GRAPHISOFT before 2018 are using KEXT 3G (Kernel Extension) as a default for communication with the CodeMeter Driver. With the release of macOS 10.13, Apple introduced a strict policy where 3rd party USB devices which use Kernel Extension need to be manually approved by the user in System Preferences.

 

wp-content_uploads_2017_10_Warning_18x18.png
IMPORTANT: Starting with macOS 11 Big Sur, 3rd party Kernel Extensions won't function anymore: “future OS releases will no longer load kernel extensions that use deprecated KPIs by default."

 

To be able to continue using CodeMeter Hardware protection keys on macOS 11 and later, they need to be configured as HID (Human Interface Device) rather than KEXT (Kernel Extension) on an earlier macOS version.

This conversion is done automatically in new product packages, released in 2018 and later. If you were directed here from such an installer, you can check out requirements of a successful installation below and go through the configuration with the help of the wizard in the installer.

The converter tool can be found in the following packages:


For the upgrade to be successful, there are three individual requirements:

  1. Network connection for the Firmware update
  2. CodeMeter Driver 5.0 or higher for the HID communication
  3. Network connection for the HID configuration

1. Requirements of the Firmware update

If the Firmware version of your license key is below 2.02, then it needs to be upgraded for the HID communication. The upgrade is done automatically during the conversion process, but it's necessary to reach WIBU's server for the process. Therefore in order to successfully update the firmware, http communication needs to be enabled on the Firewall or Antivirus application.

 

wp-content_uploads_2017_10_Warning_18x18.png
WARNING: Many company networks use proxy servers, which have to be configured for CodeMeter. Since CodeMeter Version 4.10a, the proxy is read and eventually transferred during installing. The setting can be read and manually changed for older versions or other individual cases. If you want to know whether a proxy is used on your network and which settings are required, please ask your administrator.

 

2. Requirements of CodeMeter Driver

For the conversion process to be successful, you will need CodeMeter Driver 5.0 or newer, because the HID communication requires at least this version.

To check your CodeMeter Driver version go to the Dashboard of your CodeMeter WebAdmin interface:

 

wp-content_uploads_2018_02_codemeter-runtime-driver-version.png

 

If your Runtime Version is below 5.00, then you'll need to update your driver before your key can be converted. To do so:

  • go to the GRAPHISOFT CodeMeter Driver download page
  • download the CodeMeter Driver for your Operating System
  • Start up the installer and first Uninstall your existing driver
  • Start up the installer again and install the new CodeMeter driver
  • Restart the computer if required

3. Requirements of the HID configuration

The ARCHICAD Update establishes communication with GRAPHISOFT's server to perform the CodeMeter Hardware key update.

In order to do that, please make sure communication with the following server is enabled: https://activity-api.graphisoft.com

(The communication is enabled when you open this URL in a browser and see this message: You do not have permission to view this directory or page.)

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!