cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

"System Extension Blocked" warning during installation on macOS 10.13 High Sierra

Daniel Kovacs
Graphisoft Alumni
Graphisoft Alumni
Affected versions: All | Severity: not a Bug, workaround applicable | ID: 229504

Issue

When you try to install Archicad, BIMcloud or the License Manager Tool on your newly installed macOS 10.13 High Sierra for the first time, you are prompted with the following warning: "System Extension Blocked"

wp-content_uploads_2017_09_System-Extension-Blocked-1-1024x549.png

 

Cause

This happens because Apple has a new policy about Kernel Extensions in macOS 10.13 High Sierra. This keeps every 3rd party Kernel Extension from running unless an Administrator user allows it. The CodeMeter driver uses such a Kernel Extension for communicating with the Hardware keys, so Archicad, BIMcloud or the License Manager Tool won't be able to communicate with them without it. Software keys don't use this Kernel Extension, so they are unaffected by this issue.

wp-content_uploads_2020_07_Info_18x18.png
 Important: Apple announced on WWDC19 the process of deprecating Kernel Extensions: “We are beginning the process of deprecating Kernel Extensions. MacOS 10.15 Catalina will be the last release to fully support Kernel Extensions without compromises. Specifically, for the capabilities supported by System Extensions and the device families supported by DriverKit, using a Kernel Extension to do that same job is now deprecated and a future release of macOS will not load Kernel Extensions of these kinds. In future releases we will add more kinds of System Extensions and more device families to DriverKit. In turn Kernel Extensions of those kinds will also be deprecated." Solution You need to manually Allow the Kernel Extension to run (you only have to do this once on each computer). Here's how you can do it: during the installation process a panel will show up with instructions on how to enable the Kernel Extension:
wp-content_uploads_2017_10_Kernel-Extension-warning-installer-button.png
Just press the Go to Security & Privacy Settings button and then click the Allow button next to the "WIBU-SYSTEMS AG" text:
wp-content_uploads_2017_07_Security-Privacy-1024x899.png
If you forgot to do this during the installation, then here are the steps you need to make:
  1. restart your computer (the dialog to Allow the Kernel Extension only appears for half an hour, after every startup)
  2. Open the System Preferences Application
  3. Select the Security and Privacy Submenu, and go to the General tab.
  4. Click the Allow button next to the System software developer "WIBU-SYSTEM AG" was blocked from loading message.
wp-content_uploads_2017_10_Warning_18x18.png
 Because of security reasons pressing the Allow button won't take effect if you are connecting to the machine via Remote Desktop, or if the mouse/trackpad is emulated by a 3rd party application (MagicPrefs, BetterTouchTool, Synergy, etc.)

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!