Archicad C++ API
About Archicad add-on development using the C++ API.

Develop ArchiCad 18 addon with Visual Studio 2013

Anonymous
Not applicable
Hi

Does that possible to create AC 18 add-on with Visual Studio 2013.
Strange thing is when I install API DevKit, wizard compatible only with Visual Studio 2010.
3 REPLIES 3
Ralph Wessel
Mentor
ggiloyan wrote:
Hi

Does that possible to create AC 18 add-on with Visual Studio 2013.
Strange thing is when I install API DevKit, wizard compatible only with Visual Studio 2010.
The API documentation specifies VS2010. I don't know if 2013 is considered compatible.
Ralph Wessel BArch
poco2013
Mentor
FYI:

Add-Ons should compile with any of the latest versions of VS. However the add on examples are supplied with a version of the vsxproj file that will only compile with VS version 2010. You can. however, compile them with 2013 by setting its version control to 2010. This assumes that VS 2010 has also been previously installed.

This is my problem, my VS 2010 has been corrupted so not usable. Since I'm on 2013 and installed all versions by download, I can not go back and reinstall 2010. So no solution -- hopefully the Archicad release 19 will. at least, use VS 2013 since VS 2015 is now out. Archicad is definitely not friendly to Windows users?

BTW the MAC versions works fine withe the latest XCode compiler.
Gerry

Windows 11 - Visual Studio 2022; ArchiCAD 27
Anonymous
Not applicable
Thanks for the answers!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!