Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

MEP Modeling junction does not work when first element is placed using MEP Routing

Not applicable
I'm very new to Archicad - I've only had it for about a week and a half now - so this might just be me being dumb/inexperienced with the program, but I can't seem to find a way to fix it.

For a project, I need to design the installations/services in a building. To do this, I watched a couple of videos to see how this works with Archicad, before trying to use the MEP Routing tool to do it myself. After some initial problems, I finally got the hang of laying down some ducts and pipes.

Now, however, I wanted to add a junction to one of the ducts. I used the MEP Routing tool to try and add it like was shown in the videos, but after selecting the type of junction I wanted to add to the duct, the routing tool stopped (it finished the routing immediately).

I then tried to add it manually, and while unlike with the routing tool, I could place the junction, the proportions of all the elements were wrong, and it wasn't connected to the duct at all.

After this, I started experimenting a little to try and find out what the problem was. I asked my partner for this project to try it, and it worked fine for him. I originally thought that the problem was in the size of the ducts because the ducts I used were quite small, and I had a problem with the dimensions earlier (I couldn't make a right angle because the first part of the pipe wasn't long enough), and when I tried to do it with the standard dimensions, (800 by 500 mm I believe), It worked for me as well, but when I actually started to add the bigger ducts into the design, it still wouldn't work. I increased the size of the ducts all the way up to 1000 by 1000 mm (a little over 3 ft.), but it still wouldn't let me place the junction.

I then, mostly by accident, placed down a duct without using the Routing tool, and I could suddenly add the junction again. I lowered the dimensions again, and I still didn't have a problem, but when I tried to add the junction to a duct that I placed with the routing tool, it didn't let me do it.

If anyone has any idea how to help me, I would really appreciate it. I can't find any information about this, and I've been trying to get around this for hours now, and I still haven't been able to do it. I could add the ducts manually, but that just seems like an enormous waste of time if I can make this work (and I don't see why this would be an intentional feature).

I can use the MEP Routing tool to add junctions to ducts that are placed manually, but when I try to do it with ducts that are placed with the routing tool, it doesn't allow me to do so.

Not applicable
For those people that are still wondering how they can get around it, I have found a way.

When you use the MEP Routing Tool, the pipes/ducts/cables you create are made as a group, which means that you cannot select a single element, and apparently you can't change the element either. To get around this, just ungroup the elements (select the element you want, then press Ctrl + Shift + G; or Edit>Grouping>Ungroup. This way you can change the elements without having to delete them, and also add the junctions to the objects.

I hope this helped some people.


When you are done editing the element, you can of course regroup the elements if you want to.

David Maudlin

Rather than Ungroup, you can Suspend Group, which temporarily turns off grouping, then Enable Groups when done. Glad you figured out a way to keep working.

You should add a Signature to your Profile (click the Profile button near the top of this page) with your ArchiCAD version and operating system (see mine for an example) for more accurate help in this forum.

David Maudlin / Architect

Digital Architecture

AC26 USA • iMac 27" 4.0GHz Quad-core i7 | 24 gb ram • MacBook Pro 2.8GHz | 16 gb ram • OSX10.15.7

A_ Smith
Stijnvdnheuvel wrote:
I originally thought that the problem was in the size of the ducts because the ducts I used were quite small
Automatic routing doesn't work if you are trying to connect 2 pieces of pipe/duct, but there is too little space to place it (the connection element is bigger than space between ducts/pipes).
Try to connect the same elements, but at a bigger distance than before. Probably that connection would be big. I mean I had the same issue with the standard MEP template. For ex., the standard radius of the elbow for pipes is ~ 150mm, meanwhile I'm using Ø32mm pipe.

I think you need manually select elbow, tee, etc. and set dimensions you'd like to have. Then use automatic routing.
AC 22, 24 | Win 10

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!