cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.
SOLVED!

Problem when using expressions to calculate the number of occupants automatically

Achille Pavlidis
Enthusiast
Hi,

I;m struggling with the following: I use follow the directions of this page: https://helpcenter.graphisoft.com/knowledgebase/86867/ to calculate the number of occupants. The problem I face is when I have a parameter of occupancy that is not an integer, like say 2.6 or 3.2 those number get rounded up resulting in erroneous results. The expression used is
STRTONUM ( SPLITRIGHT ( {Property:ZONES/Occupancy type}, "| ", 2 ) )

Why is this happening? Does the roundup function in the Occupants affect also the Occupant load value?
Mac OSX 13.6.6 | AC 27 INT 5003 FULL
1 ACCEPTED SOLUTION

Accepted Solutions
Solution
runxel
Legend
Be sure that the "occupants load" number is a real, natural number (float), and not an integer; this is to be set in the property's value type.
Then everything should work fine.

I am not aware what the decimal seperator in Greece is. In Germany it's the comma.
You'll need to have the number in "occupancy type" be in the same format as per your PC's settings.

Lastly I would rather "ROUNDDOWN" than up... since rounding up makes no sense – if there is not enough space left you can't cram more people in, right?!
Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text | My List of AC shortcomings & bugs | I Will Piledrive You If You Mention AI Again |

«Furthermore, I consider that Carth... yearly releases must be destroyed»

View solution in original post

2 REPLIES 2
Solution
runxel
Legend
Be sure that the "occupants load" number is a real, natural number (float), and not an integer; this is to be set in the property's value type.
Then everything should work fine.

I am not aware what the decimal seperator in Greece is. In Germany it's the comma.
You'll need to have the number in "occupancy type" be in the same format as per your PC's settings.

Lastly I would rather "ROUNDDOWN" than up... since rounding up makes no sense – if there is not enough space left you can't cram more people in, right?!
Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text | My List of AC shortcomings & bugs | I Will Piledrive You If You Mention AI Again |

«Furthermore, I consider that Carth... yearly releases must be destroyed»
Achille Pavlidis
Enthusiast
Thanks @runxel.

Actually I used "ROUNDUP" because I'm calculating the maximum number of people that can fit in a given space, according to the fire standards
Mac OSX 13.6.6 | AC 27 INT 5003 FULL