Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

All parameters lost in GDLs

Hubert Wagner
Participant
Hello :
I've opened a project I've not worked on for quite a long time. All the parameters for the many GDLs the project contains are lost. As far as I'm aware nothing has changed. It's the same file. My GDL library is the same, the path name to the GDL library has not changed and I'm using the same version of ArchiCAD.
When I opened the file, the library loading report says "GDL Library unavailable".
After loading the GDL Library, the objects appear but settings revert to the initial settings in the GDL not the parameters set after the GDL was chosen and defined.
e.g. GDL 'keta-parametric' length set to 400 cm, initial length in GDL before setting = 100 cm
When the GDL library is loaded, all ketas are reset to 100cm

Note : I've discovered the "House" folder which contains all my files and projects is duplicated in the 'Documents' folder. I'd forgotten I'd done this for backup purposes. So there are two path names.
iHD:Users:HubertWagner🏠GDL Library
iHD:Users:HubertWagner:Documents:House:GDL Library

I've tried opening the project and reloading the library from both locations. Same problem.
How do I resolve this problem?

Regards : Hubert Wagner
1 REPLY 1

Peter Baksa
Graphisoft
Graphisoft
Hi,

Is it possible that the library uses some external file that's not included in the backup?
Péter Baksa
Software Engineer, Library as a Platform
Graphisoft SE, Budapest

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!