cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Developer forum

Compile addon on OSX 12.1

abrakadabra
Contributor

Hello,

 

I have a new imac with OSX 12.1 on ARM platform. Unfortunately I cannot compile because of error below. 

Is it supported to use Archicad 25 SDK on ARM platform? 

 

X.xcodeproj: error: The linked framework 'UC.framework' is missing one or more architectures required by this target: arm64. (in target 'CF Release' from project 'CF_25')

 

1 REPLY 1

Akos Somorjai
Graphisoft
Graphisoft

Hello,

 

ARM platform support is coming, but not there yet.

 

Please set the Architectures in Build Settings to x86_64 instead of Standard Architectures.

 

Best, Akos

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!