Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Graphic UI Text Bug - UI_OUTLINE is cut short

jakubc7
Booster
I found that ever since version 24 (and still on 25) my graphic user interface text gets cut off short when using the UI_OUTFIELD command. This was not an issue v23 and earlier. Any insight would be appreciated.

Partial code for reference:
!!!---Column 1---

!!!---Line 1---
UI_STYLE 0,1
UI_OUTFIELD "2D Settings", 0,45

!!!---Line 2---
UI_STYLE 0,0
UI_OUTFIELD "Symbol Selection", 0,70
UI_INFIELD "symbol", 100, 65, 100

!!!---Line 3---
UI_OUTFIELD "GPO Type", 0,95
UI_INFIELD "gpo_type", 100, 90, 100

!!!---Line 4---
UI_OUTFIELD "Scale with Paper", 0,120
UI_INFIELD "use_scale", 100, 115, 100

!!!---Line 5---
UI_STYLE 0,1
UI_OUTFIELD "2D Representation", 0,145

!!!---Line 6---
UI_STYLE 0,0
UI_OUTFIELD "Outline Pen", 0,170
UI_INFIELD "pen_GPO", 100, 165, 100

!!!---Line 7---
UI_OUTFIELD "Fill Type 1 | Pen | BG", 0,195
UI_INFIELD "fill_solid",100 ,190, 30
UI_INFIELD "pen_fill_solid", 135, 190, 30
UI_INFIELD "pen_bg_solid", 170, 190, 30

!!!---Line 8---
UI_OUTFIELD "Fill Type 2 | Pen | BG", 0,220
UI_INFIELD "fill_empty",100 ,215, 30
UI_INFIELD "pen_fill_empty", 135, 215, 30
UI_INFIELD "pen_bg_empty", 170, 215, 30

!!!!---Line 9---
UI_OUTFIELD "Origin | Pen | Line", 0,245
UI_INFIELD "show_origin", 100, 240, 30
UI_INFIELD "line_origin", 135, 240, 65
ArchiCAD 10 - 25 | Windows 10

ARCHIcreate | Perth, Western Australia
archicad solutions | content creation | training | software implementation
1 ACCEPTED SOLUTION

Solution
Barry Kelly
Moderator
I see you are specifying the position of the infield but not its size.
I never knew it was an option not to.

UI_INFIELD "name", x, y, width, height [, extra parameters ... ]
[ UI_TOOLTIP tooltiptext ]


So I would use something like...

!!!---Line 3---
UI_OUTFIELD "GPO Type", 0,95, 100,15
UI_INFIELD "gpo_type", 100, 90, 100,15


You can use the 'Check' button to see if fields are overlapping.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

3 REPLIES 3

Solution
Barry Kelly
Moderator
I see you are specifying the position of the infield but not its size.
I never knew it was an option not to.

UI_INFIELD "name", x, y, width, height [, extra parameters ... ]
[ UI_TOOLTIP tooltiptext ]


So I would use something like...

!!!---Line 3---
UI_OUTFIELD "GPO Type", 0,95, 100,15
UI_INFIELD "gpo_type", 100, 90, 100,15


You can use the 'Check' button to see if fields are overlapping.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

jakubc7
Booster
Thanks Barry. Adding the width and height does the job.
I recall the need or rather option for it now but always got around it by not entering the size as there were never any errors or overlaps when I "checked" the UI. It's almost like the developers are now forcing a "wrap text" option when it wasn't the case before.

See attached for reference ... version 22 and no issues. Pretty sure 23 was also fine. Wonder why they changed the behaviour in 24+ ...?
ArchiCAD 10 - 25 | Windows 10

ARCHIcreate | Perth, Western Australia
archicad solutions | content creation | training | software implementation

Peter Baksa
Graphisoft
Graphisoft
UI_OUTFIELD should work without specifying width and height.
I tried it and Win display scaling above 100% causes cropping.
I will report it as a bug.
Péter Baksa
Software Engineer, Library as a Platform
GRAPHISOFT SE, Budapest

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!