Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

pen stuck

A_ Smith
Advocate

Archicad 24. Does anybody knows about some global settings or smth like this that controls behavour/pen represantion? Till now all my objects were working ok and they still do. But I got pln file from architect and only for that file I have issue with basicly all my objects (not standard obj, they work fine). To be precise - their line represantion (its colour).

It happens for 2D (only 2D script) and 3D objects (both scripts). No matter what pen I pick its always stay #1 (first one - black). I even tried to pick in object parametes #5 (blue) and override pen to #20 (red), but object remain to display pen #1. While I'm changing pen parameters at objects window, top and front preview shows how pen is changed, but after confirming (pressed OK) objects represantion remains the same. Though I found out that mine objects are not model element (for ex. inline MEP object) works as it should. But switching some objects to this type didn't in order to make them work has no effect.

 

Tbh I wouldn't notice this, if I didn't build 3D document from view. Changed this document represantion - all visible contour same pen: red. It did the job - all became red, except mine objects. They remain black.  If that would be happening in all AC24 projects I would understand that I made smth completely wrong. But all of these occurs only in that one file, meanwhile new created and all others AC24 projects don't have this issue. Objects made in AC22.

 

Any suggestions?

AC 22, 24 | Win 10
1 ACCEPTED SOLUTION

Solution
Barry Kelly
Moderator

It could also be a renovation filter setting.

The affected object may be 'existing' and are being over-written by you reno filter where as the unaffected objects might be 'new' and are not being over-written.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

4 REPLIES 4

Barry Kelly
Moderator

Have you got the pen over-ride active in some of the object settings?

If this is active it will not use the object pens and lines.

 

BarryKelly_0-1653449524326.png

 

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Pen override isn't active. More of that, if I activate it, it doesn't have any effect...

AC 22, 24 | Win 10

Solution
Barry Kelly
Moderator

It could also be a renovation filter setting.

The affected object may be 'existing' and are being over-written by you reno filter where as the unaffected objects might be 'new' and are not being over-written.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

It was combination of reno filters and graphical override...

Thank you for your help

AC 22, 24 | Win 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!