Choose your top Archicad wishes!

Read more
Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Custom Fill Pattern Unit size shows wrong dimensions

alexliz23
Enthusiast

I am trying to create a new Symbol Fill for the honeycomb pattern of insulation. I have drawn the pattern in 2D using Lines only, and my pattern XY size is (in mm) 43.4 x 50.0. I copy it onto my clipboard, then I create a new Symbol Fill and select the "Scale with Plan (Model Size)" option. At that point, I note that the greyed-out fields for "Pattern Unit size: [m]" fields show 1.000 for both X and Y.

 

I then press the Paste button. 

I see that the greyed-out fields switch to a seemingly-unrelated value; X becomes 5.2585, Y becomes 0.2759. These values are also the ones I see in the fields lower down, for "Strokes [m]", in the Horizontal and Vertical spacing fields.

 

I proceed to just those last two (editable) fields to the correct values for my pattern, ie 0.0434 and 0.05, at which point the pattern preview is corrected (I may need to zoom out a bit to see this).

 

Anyone can shed any light as to why the greyed-out values are wrong? Do you happen to know what the logic is there? Many thanks.

 

PS As a side-note, see the tiny red dots that are included in the fill when I place it, in red, at left? They are also visible within the Fills editor preview pane, but do not exist in my pattern so I have no idea why they show.

 

NEW SYMBOL FILL.png

 

Operating system used: Mac Intel-based 14.3.1 Sonoma

Archicad 27 macOS Sonoma
12 REPLIES 12
alexliz23
Enthusiast

I have now started a new project file, based on the 27INT template. I drew the honeycomb pattern using 13 Lines and created the new Symbol Fill successfully. The pattern is correct, and is correctly dimensioned at the moment I click on the Paste button - the X and Y dimension fields are automatically populated with the correct values from my copied lines at the previous step. I play around with the newly created fill in the .pln file where I created it, all is good.

 

I copy the generating lines as well as the sample fill from my 2D window, save this new project .pln and then open the project file where I am working (and where I have the issue described in the original post). I paste.

 

Dots or no dots.png

 

The fill which I brought in shows correctly - no dots. I then select and copy the 13 lines which I pasted (which I had copied together with the fill from the 2D window in the newly-created 27INT template) to create the same fill within the real project file. The copied pattern is 75mm across and 86.6mm tall:

 

 

Pattern Lines and dims.png

When I click on the "Paste" button, the "Pattern Unit size: [m]" X and Y fields are auto-populated with wrong values, and I get the extra dots in the pattern. I have to go down to the "Strokes: [m]" fields and adjust the X and Y values to the real ones so that the pattern repeats correctly (but I still get the dots, and the Pattern Size values at top are the wrong ones):

 

Fill params.png

 

While searching online, I stumbled upon Robert Mann's YouTube video who presents how to create Symbol Fills, and I noticed that the fill he creates in his video also shows dots which weren't included in the lines he used to generate it - see here at the 00:09:48 mark: https://youtu.be/MIuH3mncRKU?si=4a5gUhHCso3kGGCP&t=588  ― which makes me wonder: could it be a setting somewhere (ie the Fill tool settings at the moment of creation, environment parameter etc) which causes the dots to appear in some cases? Anyone stumbled upon this and who could shed some light?

Archicad 27 macOS Sonoma
kevin498
Participant

@alexliz23Official Site wrote:

I am trying to create a new Symbol Fill for the honeycomb pattern of insulation. I have drawn the pattern in 2D using Lines only, and my pattern XY size is (in mm) 43.4 x 50.0. I copy it onto my clipboard, then I create a new Symbol Fill and select the "Scale with Plan (Model Size)" option. At that point, I note that the greyed-out fields for "Pattern Unit size: [m]" fields show 1.000 for both X and Y.

 

I then press the Paste button. 

I see that the greyed-out fields switch to a seemingly-unrelated value; X becomes 5.2585, Y becomes 0.2759. These values are also the ones I see in the fields lower down, for "Strokes [m]", in the Horizontal and Vertical spacing fields.

 

I proceed to just those last two (editable) fields to the correct values for my pattern, ie 0.0434 and 0.05, at which point the pattern preview is corrected (I may need to zoom out a bit to see this).

 

Anyone can shed any light as to why the greyed-out values are wrong? Do you happen to know what the logic is there? Many thanks.

 

PS As a side-note, see the tiny red dots that are included in the fill when I place it, in red, at left? They are also visible within the Fills editor preview pane, but do not exist in my pattern so I have no idea why they show.

 

NEW SYMBOL FILL.png

 

Operating system used: Mac Intel-based 14.3.1 Sonoma


When creating a new Symbol Fill for a honeycomb insulation pattern, you may encounter incorrect values in the greyed-out fields due to scaling discrepancies or internal calculation errors. Adjusting the editable fields for spacing can correct the preview to reflect the intended pattern size. As for the appearance of tiny red dots within the fill, these may be rendering artifacts that don't exist in the actual pattern and can be disregarded. If issues persist, consulting the software's documentation or support team may provide further insight.

Hi Kevin, thanks for the time you took to type this.

Archicad can't be having 'scaling discrepancies or internal calculation erros' when measuring the X and Y dimensions of a simple line pattern spanning a few mm; nor are the dots I mention 'rendering artifacts that don't exist' (and they can't 'be disregarded', either, as they are exported to the PDFs). As to consulting the 'software's documentation or support team' ― if you have a reference in the manual let me know, I have scoured and found nothing, which is when I arrived here at the GS Community, for any real help.

 

But, like I put at the top: thanks for your time. Have a good one.

Archicad 27 macOS Sonoma
Barry Kelly
Moderator

Actually, it seems there is no need to create a 'symbol' fill for hexagons.

There must be a default 'vectorial' fill, as I have one in my template.

I just looked in the default 'AUS' template and it is definitely there.

I assume it is in other languages default templates as well.

 

BarryKelly_0-1710821058172.png

 

Just adjust the pattern unit size to suit your needs.

 

Barry.

 

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry, many thanks, I located the 'hexagonal' fill in my INT as well - I knew I'd seen it before, but I must have been searching while limiting to 'building materials' so it didn't come up (and I didn't go into Attribute Manager to double-check...).

 

OK, that's great. But I am still at a loss as to what is happening with the dimensions which get auto-populated wrong, plus the annoying dots that get added to my pattern and also make their way to the exported PDF drawings. Any ideas as to that?

 

Thanks again.

Archicad 27 macOS Sonoma

@alexliz23 wrote:

OK, that's great. But I am still at a loss as to what is happening with the dimensions which get auto-populated wrong, plus the annoying dots that get added to my pattern and also make their way to the exported PDF drawings. Any ideas as to that?


I am not sure what has happened for you.

All I can think of is you somehow selected a small line (the dot) that threw off your pattern size and shows on plan as a dot.

 

I just tried copying lines from a plan set to 1:100 scale (not sure if that is important).

It all seems to have worked perfectly.

This is in Archicad 25 - all I have open at the moment.

 

BarryKelly_0-1710836521844.png

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hmm... the 'wrong dimensions' issue is intermittent: sometimes it does show the correct values for me, as well.

 

However, the other issue is happening every time I include a hotspot in the copied elements and paste into the fill generator. They show as 'dots' in the plan/section etc views. They also make it to the layouts and, sadly, into the finished deliverables, ie the PDF drawings.

 

Depending on output scale/pen thickness these printed dots can go undetected to those who are not looking to see them. In 1:10 / 1:20 or even larger detail drawings, however, they become very noticeable. I wonder if it's a bug. I will do some further troubleshooting using New & Reset All (also I might set a new user account on my Mac and try from there) and report back here.

Archicad 27 macOS Sonoma

I can confirm, if you copy any hotspots into the fill as you create it, they will show as dots in the final fill.

I guess they will print because they are not really hotspots any more.

 

And if they are outside of the pattern extents that you copy, they will affect the pattern unit size.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry, I think I've got somewhere.

 

I have just copied the lines showing selected below:

alexliz23_0-1711138374336.png

When I go into the Fills editor and paste, this is what I get:

Fill editor.png

You can see the Pattern Unit size fields being wrong; also I have marked in red a few only of the dots that show in the preview. Please note I haven't included any Hotspots in the copied elements when setting the fill up. You can see more dots in the Pattern preview pane, as I didn't highlight all of them.

 

Even though I can adjust the dimensions in the Strokes fields (and forget about the wrongly pre-filled values for now), the dots do show in the plan/section etc and they do get exported to the PDF sets.

 

I then thought to try and create the exact same fill in a brand new project, so I did New from the v27 template. It worked fine. Correct dimensions. No extra dots. I drew a fill in there, then copied and pasted it into the previous project, the one where I get all the issues. The fill shows fine.

 

Then it hit me - I had been creating the new fill inside a Worksheet. I copied my pattern-generating lines from the Worksheet window, went into the plan view, pasted them and generated a new fill from there. All is good.

 

Bottom line, as far as I can gather at this point: Archicad seems to struggle when I create the fill from anywhere other than the plan view. Does that sound like a bug or would you say it's by design?

 

Archicad 27 macOS Sonoma

Setup info provided by author