Choose your top Archicad wishes!

Read more

Fonts/Characters - Troubleshooting Guide

Katalin Borszeki
Graphisoft
Graphisoft

Postscript Fonts are not displayed in PDF

For this issue, please see the PDF Troubleshooting Guide

Special Characters on Mac

Affected version: 16 | Severity: workaround applicable | ID: 158311
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
wp-content_uploads_2016_06_Info_18x18.png NOTE: This issue was fixed in ARCHICAD 17 release version.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Issue
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Special language characters do not appear right in texts on Mac.

 

Cause

A possible cause is that the language settings of your system do not match the input language you use

Solution.

In System preferences under Language & Text settings, set the desired language first in the Language tab, and also check the checkbox of the wanted language in Input Sources tab.
wp-content_uploads_archicadwiki_bugs-specialcharactersonmac--language-text.png

Lithuanian character problem

Affected version: 16 | Severity:workaround applicable | ID: 156033
 
wp-content_uploads_2016_06_Info_18x18.png NOTE: This issue was fixed in ARCHICAD 17 release version.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Issue
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
It is not possible to write in Lithuanian language ( which belongs to Central Europe CE or Baltic) in the project info box, navigator, zones and so on. Its not possible to get any special character in fields. Lithuanian language is selected and placed on top of all others. Under format region Lithuania selected too. Input menu Lithuanian keyboard. So all the things that should impact the program is set up, but no results. There is no problem to write in Lithuanian language on the plan using text tool.

 

Cause

This setting should work, but they do not, because the baltic languages are not script based but unicode based.

Solution

  • Step1: In System preferences / International / Language first is Lietuviu (Lithuanian). This is correct on the screenshot.
  • Step2: logout and login
  • Step3: this can solve the problem:
Please set Hungarian or Czech language for the second language.

Cyrillic Font Problems

 

Issue

While using Cyrillic names and parameters, the text turn into unreadable characters.
 
wp-content_uploads_2016_06_Info_18x18.png NOTE: The Cyrillic alphabet is used by a wide variety of Slavic languages—Belarusian, Bulgarian, Macedonian, Russian, Rusyn, Serbian, and Ukrainian—as well as many other languages of the former Soviet Union, Asia and Eastern Europe.
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--01.jpg

 

Cause

The reason is that the needed character sets are not setup.

 

Solution

Cyrillic character settings on Windows

The "Regional and Language Options" set in the Control Panel is as follow:
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--x1.jpg
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--x2.jpg
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--advanced.jpg
  • In the ARCHICAD folder is a folder calls Add-Ons. Double click on it and in the XReadCfg.txt.file setup the ID for 7.
 
wp-content_uploads_2016_06_Info_18x18.png NOTE: this is the conversion ID for Russia and Bulgaria etc.
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--02.jpg
  • Access the registry, select "RUN" command in the Start menu, and type "regedit".
Then set registry key HKEY_CURRENT_USER\Software\Graphisoft\ARCHICAD\ARCHICAD 11.0.0 INT R1\Font Description\Font Script Code to 204.(Russian Character set)
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--03.jpg
After all this steps, ARCHICAD will recognize all the parameters.
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--04.jpg

Cyrillic character settings on Mac

 
wp-content_uploads_2016_06_Info_18x18.png NOTE: on Mac is no registry available.
  • open the system preferences
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--1.jpeg
.
  • select the international icon
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--2.jpeg
  • edit list (select the language, for example Russian)
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--3.jpeg
  • make sure, that the selected language is in the first position
wp-content_uploads_archicadwiki_bugs-cyrillicfontproblems--4.jpeg
After this steps restart the computer.

Mac Text Problems

 

Issue

  • When migrating projects from ARCHICAD13 to a later version, text base line or row spacing changes
  • Some Fonts lose the "bold" or "italic" options
  • Some Text's font changes - original font is not available, and is replaced by something else
  • With black background, caret (AKA. "blinking cursor") is not visible

 

Cause

ARCHICAD 13 (which was a Carbon application) used the ATSUI Text engine, which is being phased out. Since version 14 ARCHICAD is a Cocoa application, it uses the Core Text text engine, which is used by most of the current Mac applications. Some older fonts are not fully compatible with the new text engine.

 

Solution

Check the Font in TextEdit, Apple's own text editor program, which also uses Core Text. If the problem comes there too, then more than likely you need to replace the font with a newer version. Get in touch with the publisher of the font.You can tell the publisher, and the published date of a Font by right-clicking the Font file, and clicking Get Info. (Font files are either in /Library/Fonts, /System/Library/Fonts or Userhome/Library/Fonts) Any font published after 2006 has a better chance to work with Core Text. It's best to use Fonts that come installed with OSX.For example a font similar to the commonly used "Mr. Hand" can be downloaded for free at this link: "Flux"This site also has a good set of free fonts.

wp-content_uploads_archicadwiki_bugs-mactextproblems--avenir.png

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!