cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

GDL
About building parametric objects with GDL.
SOLVED!

GDL Object parameter unit (square meters, volume, etc..)

alegafs_92
Participant

Hi everyone,

 

my question regards the measure unit of the parameters of a newly created GDL Object.

In my case I want a parameter representing the Area of a specific face of my object, so I want that parameter to have "m2" unit when I sum it in schedules.

How can I do?

 

Thank you very much

1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Barry Kelly
Moderator

Unfortunately I don't think there is anything you can do.

Although you can make the parameter represent the unit of measurement that you want, it is really still just a number.

Numbers in schedules do not have units, so you won't get the unit of measurement in the schedule unless you add it to the title of the column/row.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

View solution in original post

2 REPLIES 2
Solution
Barry Kelly
Moderator

Unfortunately I don't think there is anything you can do.

Although you can make the parameter represent the unit of measurement that you want, it is really still just a number.

Numbers in schedules do not have units, so you won't get the unit of measurement in the schedule unless you add it to the title of the column/row.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
alegafs_92
Participant

Hi Barry,

yes, it is what I did, I've created a parameter with Real number and gave it the unit (m2) in the title. Not too bad

 

Thank you for your reply! 😉