BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Visualization
About built-in and 3rd party, classic and real-time rendering solutions, settings, workflows, etc.

Shadow casting

Anonymous
Not applicable
Hi I'm a new user to Archicad and im have an issue with getting shadows to show when i put my model into perspective view in the openGL engine.

I'm pretty sure the sun is actually showing as when I change the settings I can see a change in the ambiance of the model. Where can I find the settings to make all my elements cast a shadow?.
8 REPLIES 8
Eduardo Rolon
Moderator
Right Click on empty space in the 3D window and select "3D Window Settings"
Screen Shot 2015-02-25 at 12.40.40 PM.png
Eduardo Rolón AIA NCARB
AC27 US/INT -> AC08

Macbook Pro M1 Max 64GB ram, OS X 10.XX latest
another Moderator

Anonymous
Not applicable
Ive already checked that setting and its still has no effect. I did wonder if it had something to do with the individual elements and if there is a setting to allow them to cast shadows?
Barry Kelly
Moderator
Shadows for objects can be controlled in the scripts but for other elements there is no individual control - they all have shadows.

What is the percentage of sun in your 3D projection settings?
If it is set to 0% then there will be no shadows but if you still have a decent percentage for ambient light you will still see your model as being lit.

Barry.
One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Anonymous
Not applicable
Ive been playing around with the 3d projection settings and still no shadow when the model is in perspective. Would it be possible for you to send me a screen shot or your settings so i can replicate that to see if that will fix the issue?
Barry Kelly
Moderator
Does this help?
3D window is viewing with OpenGL with shadows "On".

Barry.
sun_settings.jpg
One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Anonymous
Not applicable
Hi Thanks for this i have figured out what the issue is. The settings where right but my graphics card isn't up to scratch which is why i can see shadows with the internal engine and not openGL.

Thanks for all your help though, looks like i need to get a new laptop!
Aquavit
Contributor
Hi i know this is a bit late to the party but I am having a similar issue... In my current model, the shadows seem to only be cast by the buildings, not trees, etc. I've not had this problem before, and don't believe I have changed any significant settings...

I've reviewed 3d styles (mac, 3d window settings) as suggested below (see attached) and played around with sunlight settings (attached also) for both a typical model that works and my current one that does not for some reason.

Any top tips gratefully received...

AC26 3001 INT FULL - Laptop Win10 x64 - Intel i7-7920 HQ CPU @ 3.10GHz - NVIDIA Quadro P3000
Anonymous
Not applicable
Did you check your trees settings if they have the shadow options disabled?
Learn and get certified!