cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Archicad C++ API
About Archicad add-on development using the C++ API.

Compiled bundle stops working all of a sudden

vdentello
Advocate

It's the second time it happened already, there's no apparent reason.
Learning it has been exciting and a nightmare at the same time.

I was trying some new IFs to deal with geometry changes within the code, but, I made a mistake, it still compiled and it crashed Archicad. Okay.

I reverted the code to the previous version...
But from now on it's forever greyed out, even though it's the EXACT SAME CODE that worked before. 

It happened yesterday, I had to recreate all the template from scratch and copy the same code lines, and it worked again. The warning says that it's no an extension anymore or it's outdated. 

Screenshot 2023-10-25 at 11.34.14.png

I got it removed to try to reload, but nothing happens. Clean build folder, build...

 

Screenshot 2023-10-25 at 11.43.09.png

 

I've come to notice that rules show stamp.rule appears like that. I never touched it, it was working before.

It was never edited anyway.

Screenshot 2023-10-25 at 11.49.37.png

 

 

 

Archicad User Since 2013
GDL Developer
Experimenting with API
from Brazil
2 REPLIES 2

Hi Vítor,


This is annoying and it happened to me before as well. Unfortunately there are a lot of different reasons why this can happen.
Here are just a few thoughts/steps to try:

  1. When removing the Add-On (click on yellow warning sign, then remove button becomes active), make sure to also close the Add-On manager with OK. Only after closing the Dialog with OK the Add-On is really removed.
  2. Clean the build folder and regenerate the project with CMake
  3. Make sure to use the correct build target in XCode
  4. The file AddOnResources.stamp.rule is generated by CMake (or XCode when building from a CMake generated project), so that's why it might show up as changed although you don't change it manually.

Hope that helps,

Bernd

Bernd Schwarzenbacher - Archicad Add-On Developer - Get Add-Ons & Archicad Tips on my Website: Archi-XT.com

I was getting tired of having to back to the beginning and started to try every hypothesis.

It was loaded and running in an instance of archicad, showing up new compiled differences and it was all ok.
But as I opened a new instance, it would show greyed up.

Upon trial and error, under thew build settings, I tried changing it to 10.11.0, which is the one mentioned at the warning. But the Lowest it goes is 10.13. Even though it show a warning, it did the trick.

I compared and inspected other plists from running and figured out that the minimum system version seemed to prevent the load of an add-on.


I guess it could be what you mentioned by "Make sure to use the correct build target in Xcode", but I didn't quite understand it and finally got it now.

 

Screenshot 2024-04-24 at 22.11.38.png

Archicad User Since 2013
GDL Developer
Experimenting with API
from Brazil