Archicad Python API
About automating tasks in Archicad using the Python API.

M1 Mac - 26 build fails with "python: command not found"

Ben Cohen

Hi All


OK have cmake running and have my VS and Xcode projects appearing.

Now I am having issues with building an example project on the Mac.

PC also had this issue but installing Python fixed it..


On the M1 mac 

Python is installed with version 3 and 2.7


Side issue:-------

I tried checking if my Archicad 26 Python palette was working.

But I got this message

"Python Palette is only available with SSA subscription."

I have a developer license and can't access Python ?!!🤷🏼‍


I have updated the project Architecture to "x86_64" to no avail


Anyway, I can't get any example project to build and it looks like Python is the problem.. 

If anyone could help, it would be greatly appreciated.. TIA



Ben Cohen
Mac and PC
Archicad (Latest Version) aus
Ben Cohen

OK.. I have now tried on my old Intel mac with the same error..


Has ANYONE had success compiling a version 26 example project on Mac?

Ben Cohen
Mac and PC
Archicad (Latest Version) aus

Hi Ben,


I'm able to compile Add-Ons on an M1 Mac for AC26, but I had a similar issue. My fix was to change the relevant line in CMakeLists.txt from "python" to "python3" (it's line 149 in the example add-ons). Alternatively you could make the command "python" available by other means e.g. a symlink. Let me know in case that you need more information. You can always check in your terminal if the commands "python" or "python3" are available.

As for the AC26 python palette. I also have a developer license and I'm able to use the python palette also in AC26. I recently renewed my developer license and it took a few weeks after that for GS to upgrade it to AC26. Does the license manager say, that you have a AC26 license?


Best, Bernd

Bernd Schwarzenbacher - Archicad Add-On Developer - Get Add-Ons & Archicad Tips on my Website:

Thanks Bernd


I should have worked that out!!.. 

I had to modify one of my scripts like this a few months ago..


I am now able to compile ... 👍


The entire Mac development process is obscure to say the least.

Cmake adjustments

Architectures set to x86_64 from arm64

Then there is the notarization process for addons

 And none of this documented AFAIK... 

I thought the 'Blog' on Archicad API would help but it hasn't been touched for years....


Anyway, lucky there are people like you around Bernd 👍 (and Gerry and others)

Ben Cohen
Mac and PC
Archicad (Latest Version) aus

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!