Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Object IDs

ivorhession
Contributor

Hey all,

 

So i am trying to automate some object IDs, something that should be simple but is turning out not to be.

 

I have built a favourites library with various objects such as lights etc (just symbolic representations), in the favourites i have given them IDs that stand for what they are like SP 01 for a spot light.

When i try and use these in the model though, rather than the object using its own ID which i have set and creating a list like SP 01, SP 02, SP 03 and so on, the object is given an ID continuing on from some other random object like a tap or vent.

I have clearly missed something but not sure what.

 

Can any one suggest what the issue might be.

 

Cheers

 

Ivor

Ivor Hession
Principal

tóg_architecture
1 ACCEPTED SOLUTION

Solution
Gerry Leonor
Advocate

couple of things:

 

  • make sure you've applied the correct transfer settings for the favourites. (see screenshot 1 below)
    i've had to create a separate set of Transfer Settings between Including & Excluding the Element IDs and/or Layers. to manage them just open the Element Transfer Settings. (you can export/import these settings between projects too)
  • GerardLeonor_0-1638148108440.png

     

  • the other thing is make sure you've correctly set the "Assign New Element ID to Each New Element" in your User Pref Schemes. (see screenshot 2 below). i don't typically use this, because i know i can properly manage the numbering of repetitve elements using the Element ID Manager.

     

  • GerardLeonor_1-1638148114304.png

     

AC22 | Win10 | 64 bit | 16Gb RAM |Intel i7 8700 @ 3.20Ghz

View solution in original post

3 REPLIES 3

Solution
Gerry Leonor
Advocate

couple of things:

 

  • make sure you've applied the correct transfer settings for the favourites. (see screenshot 1 below)
    i've had to create a separate set of Transfer Settings between Including & Excluding the Element IDs and/or Layers. to manage them just open the Element Transfer Settings. (you can export/import these settings between projects too)
  • GerardLeonor_0-1638148108440.png

     

  • the other thing is make sure you've correctly set the "Assign New Element ID to Each New Element" in your User Pref Schemes. (see screenshot 2 below). i don't typically use this, because i know i can properly manage the numbering of repetitve elements using the Element ID Manager.

     

  • GerardLeonor_1-1638148114304.png

     

AC22 | Win10 | 64 bit | 16Gb RAM |Intel i7 8700 @ 3.20Ghz

View solution in original post

Hey, thanks for the help, it was the Apply transfer Settings I was missing.  working perfectly now...

 

Much appreciated.

Ivor Hession
Principal

tóg_architecture

Barry Kelly
Moderator

In the settings for the favourites you will find 'Element Transfer Settings'.

In there you can set whether the favourites for objects include the ID or not.

 

If you don't include it, then the ID will not change and will simply increment from the last ID used - as you are experiencing.

 

If you do include it then the ID will reset to whatever you have saved in the favourite for that object.

The problem with this is it will reset to the initial ID every time you use the favourite - in your example 'SP 01'.

 

So when you place some spotlights you will get SP 01, SP 02, SP 03, etc.

Then you place a few taps T 01, T 02, etc.

Now you use the favourite for the spot light again.

It will start again from SP 01 - because that is what you saved with the favourite.

 

Or you set the element transfer settings to not include the ID (as you have now) and the spotlight will continue on from the last ID which may be T 03 or something like that.

 

So I don't think you will win either way.

 

What you must do is to ALT+click (pick up parameters) the last spotlight you placed and then place more and the ID will increment from that.

Then ALT+click the last tap and continue placing taps.

i.e. you need to manually reset the ID before you place objects.

 

Or don't worry as you place the objects.

Then when it is important you have the correct ID, select all the spotlights, go to Element ID Manager and reset them all with unique IDs.

 

Barry.

 

 


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!