About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.


Not applicable
I'm Patrick, a new archicad user. I need your support. When I'm drawing, I set my dimensions in millimetres, but when I place a drawing in master layout, the program automatically changes my dimensions into metres. How can I deal with these issues?
Help please!
Barry Kelly
Welcome to Archicad Patrick.
In the Navigator palette, along the top you will see four buttons.
Project Map.
View Map.

If you are using View Points in the Project map, you have manual control of all of the settings for dimensions, scale, pen set graphic overrides, etc.
The easy way is to set them via the buttons at the bottom of the view window.

You should be saving these view points as 'Views' that will be located in the View Map.
These 'Views' are saved with the settings you want for dimensions, scale, pen set graphic overrides, etc.
So you no longer have to manually control them.
Then can be altered in the 'View Settings'.

You then place these 'Views' from the View Map on the Layouts as 'Drawings', and then later you can Publish them.

So in your case, make sure you have a View in the View Map that has the correct setting for the dimension style you want to show.
Then place that view on the layout.

You can have as many Views of the same View Point as you want.
So you can (if you want to) have a View of a plan with the dimensions as millimeters, and another with dimensions as meters, and another in feet and inches.

The same applies for all the other settings, scale, pen set graphic overrides, etc.
You simply set up the Views in the View Map as you want to see them, and place those Views on the Layouts.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!