BIM Coordinator Program (INT) April 22, 2024
Find the next step in your career as a Graphisoft Certified BIM Coordinator!
Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Layouts

Anonymous
Not applicable
Hi yet another question from me!

Ok, i need to layout my sheets now ive completed my drawings. Im trying to set out an A1 sheet with plans + sections @ 1:100 and renders etc. But im hitting a few hopefully minor snags.

This is what i do.

-Open plot maker v3.0
-open a new layout book defaulting all settings
-File>Import>archicad.pln file
- it warns me that project is already open in archicad, i press cont
-I select the story-0 and place drawing on current layout
-i press import. Import in the background appears
When import finishes it says "error while loading library parts elements" i select close
-my plan appears on the layout but how do i know how big the layout paper is? if i goto page setup and select A1 no proportions of the layout change from if it was set to A4?????
-Ive now selected the plan and moved it but the plan has vanished leaving me with a black square outline with the word 0.story @ the bottom?? is it supposed to do that? will it print ok even though the actual graphics are not there just the outline of the window???
-i then import a section from the same .pln file using the same process onto the same layout to place next to the plan. The update proceeds to about 25% (two beeps)
-I then get an SISGL window saying "warning, cannot create a new surface, out of video memory. This program will exit" i click ok (the only thing to click)
-a window appears saying "Error while generating view in ArchiCAD."?
-my layout currently looks like the picture ive posted.


Please help, i have less than a week to get all my drawings presented for my final crit, the pressure is on




plotmaker help.JPG
10 REPLIES 10
__archiben
Booster
bryan

i can help with some, but not all, of your issues . . .
BryanRichards wrote:
-my plan appears on the layout but how do i know how big the layout paper is? if i goto page setup and select A1 no proportions of the layout change from if it was set to A4?????
you set the plot page size from the master layout that you are using. see that box in the navigator called "Masters"? open that and select the master layout in there and then press the settings button at the bottom of the navigator. you will get a dialogue similar to the one i've attached here. as you change the plot page setup, click 'apply' or click on the white page shape at the bottom. it will update to reflect your chosen page size.
BryanRichards wrote:
-Ive now selected the plan and moved it but the plan has vanished leaving me with a black square outline with the word 0.story @ the bottom?? is it supposed to do that?
i think maybe that you have moved the drawing out of frame somewhere. if you miss one of the corner/side nodes of the frame when you drag it, and instead click somewhere within the frame, you actually end up moving the drawing elements themselves relative to the frame. try resizing the drawing frame to make it very big: zoom out and then drag the corner nodes one-by-one diagonally away from the frame. does your drawing reappear?

alternatively, try right-clicking one of the drawing frame nodes and choosing "Drawing Settings" from the drop-down menu. how is your drawing set to show on screen? there are options (i think, as i'm not actually in front of a layout at the moment) to show it in full colour, b+w bitmap, or simply as a frame. . .
BryanRichards wrote:
will it print ok even though the actual graphics are not there just the outline of the window???
depending on the settings i have just described, yes it will print OK - provided that you are sure the drawing is actually within the frame shown. that's to say, if you choose to display your drawings in anything other than full colour (b+w bitnmap/frame only) it will show as such on screen, but print/plot just fine the way you have set it to in your Book->Book Settings and each individual drawing settings (Edit->Drawing Settings or right-click with the drawing selected).
BryanRichards wrote:
-i then import a section from the same .pln file using the same process onto the same layout to place next to the plan. The update proceeds to about 25% (two beeps)
-I then get an SISGL window saying "warning, cannot create a new surface, out of video memory. This program will exit" i click ok (the only thing to click)
-a window appears saying "Error while generating view in ArchiCAD."?
this is where i can't really help you. it sounds like it could be a memory issue. you really somebody with PC experience to decipher this one.

hope i haven't served to confuse you too much. good luck with the deadline.

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup
Djordje
Ace
BryanRichards wrote:
Ok, i need to layout my sheets now ive completed my drawings. Im trying to set out an A1 sheet with plans + sections @ 1:100 and renders etc. But im hitting a few hopefully minor snags.
Quite normal snags ... and you still have not read the book, i see
-I then get an SISGL window saying "warning, cannot create a new surface, out of video memory. This program will exit" i click ok (the only thing to click)
-a window appears saying "Error while generating view in ArchiCAD."?
-my layout currently looks like the picture ive posted.
Uh - oh ... Ben answered your PlotMaker related questions, this is the PC one ...

Maybe another tip: before you import anything, shut down and restart the computer and close all other apps. What are your computer specs?

It seems that your video driver's OpenGL implementation has a lot to be desired for (with SiS not very unexpected ...) Try switching off the OpenGL everywhere in ArchiCAD, download the newest drivers. You should use a better video chipset with more memory with ArchiCAD 8.

More questions:

- how are your views defined?
- do you have your viewset defined?
- are you importing one by one (seems like it) or using the Create new layouts option (which you should)?

So, IF you have your viewset defined, in PlotMaker:

- set the Master as needed (A1 or whatever)
- make it default
- whatever shows on all sheets, let it be in the Master
- Use Autotext for sheet names, project names, etc
- when ready to import, open the PLN, choose your viewset, and import each view onto a new layout (the new layouts will be automatically created)

You cna then drag imported views from one layout to another and adjust your layout book as you wish.

HOWEVER - it sounds like you have a SERIOUS problem with the video subsystem of your computer, and of course it will show up ona deadline ...

Murphy was an optimist!
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen
Anonymous
Not applicable
oo ek!

Firstly the response effort is impressive, thanks! Ive cracked the rest of archicad im not letting this hicup stop me!

archiben:

-Right, paper lmits now understood, i can see the changes when you choose paper size

-The plans are now within my frames scaled ok.

thanks

Djordje:

-Ive just restarted my computer, closed all my apps (no music now ) maybe thats why the plan works, i always import that first

-To let you know my exact spec is http://www.uktsupport.co.uk/advent/faq/laptop/7013.htm
what do you make of this, its a laptop remember so upgrades can be a little tricky (i just got it, dont say its no good already lol )
-
It seems that your video driver's OpenGL implementation has a lot to be desired for (with SiS not very unexpected ...) Try switching off the OpenGL everywhere in ArchiCAD, download the newest drivers. You should use a better video chipset with more memory with ArchiCAD 8.
yikes, alarm bells ringing now, god help if this is a perminent problem. ok so this may seam tedious, but how do i turn off OpenGL in archicad 8?

-How are my views defined. I cannot see anything here for defining views to give an answer but i can say my plan seams ok at the minute, lets wait till i import a section

-defining my viewsets. i searched through the help for defining viewsets, i found nothing. How do i define my view sets? im obviously not doing it becasue im not sure what it is

-am i importing one by one: Well for this excersize i am importing one by one on the "current layout". Only because i thought this would have gone easier on the system resources. I would however import the .pln and select everything i need. Is this the right way of doing it?

- You say i should be creating new layout options. this will plot each drawing to a separate page, am i right?. Will i then be able to have the plan and section in the same page? and rendered images?
- set the Master as needed (A1 or whatever)
- make it default
- whatever shows on all sheets, let it be in the Master
- Use Autotext for sheet names, project names, etc
- when ready to import, open the PLN, choose your viewset, and import each view onto a new layout (the new layouts will be automatically created)
-ok got that except your last point there. (open the pln in archicad 8 first?) before importing?

-
HOWEVER - it sounds like you have a SERIOUS problem with the video subsystem of your computer, and of course it will show up ona deadline ...
-dont say that!

lets just say if all fails, ill attempt the export as .dwg and layout in ADT2004 which is not what i want to do!!!!


thanks again for this help, this is the problem when you attempt the things no one else does. YOUR ON YOUR OWN!! but not anymore.
Anonymous
Not applicable
yeah, just put in a section while archicad was open but the same sisgl problem has to close. Im left with a frame constanly saying updating, until i click stop import. (left for a good 5 minutes) 0% progress
Anonymous
Not applicable
i created a simple .pln file consisting of 4 walls and a roof, no detail, however its still giving me the out of memory window when i import a section? so is it really a memory problem? any clue?
Djordje
Ace
BryanRichards wrote:
-Ive just restarted my computer, closed all my apps (no music now ) maybe thats why the plan works, i always import that first
Don' you have a radio/walkman/whatever? Music players:

a) take up memory
b) use disk all the time

Both of the above are QUITE heavily used when Importing to PlotMaker.
-To let you know my exact spec is http://www.uktsupport.co.uk/advent/faq/laptop/7013.htm
what do you make of this, its a laptop remember so upgrades can be a little tricky (i just got it, dont say its no good already lol )
Hope it was a present ...

Rule No 1:

DO NOT TAKE A LAPTOP WITH SHARED VIDEO MEMORY!

Why? Because of your 512 MB, 64 is taken by the video memory, so that you have 448. See how much memory is used when you just start up, without any apps and deduct that number from 448. That is what you have left for ArchiCAD.

Advice: get 1MB RAM into that machine.

Rule No 2:

If you want to work with ArchiCAD 8.x do NOT take anything but nVidia or ATI video chips, with as much memory as you can pay for. SiS was never very famous for its CAD or OpenGL support. I suppose you can't change it, so now ... try to fiddle with the drivers, acceleration on and off ...

Rule of a thumb:

In the 80s, the personal computer that could run anyCAD cost as much as the software. Today it is (because the computers are MUCH cheaper) half of it. Did you pay for your laptop half the price of ArchiCAD? Thought so ...
yikes, alarm bells ringing now, god help if this is a perminent problem. ok so this may seam tedious, but how do i turn off OpenGL in archicad 8?
In 2D it is off by default, in 3D also; but this is not the problem EXCEPT if you saved your 3D views with the OpenGL active in the 3D window, in which case you will get solid black rectangles in PlotMaker.
-How are my views defined. I cannot see anything here for defining views to give an answer but i can say my plan seams ok at the minute, lets wait till i import a section

-defining my viewsets. i searched through the help for defining viewsets, i found nothing. How do i define my view sets? im obviously not doing it becasue im not sure what it is
A view set is a set of views 😉

In the Navigator, click on View sets tab. Now click on the name of the current set, a flyout panel opens and on the top is Create new set. Do it, give it a name.

Now click on the fat arrow pointing right, there is Create new view, right? Don't do it YET - first create the folders for the views: Plans, Elevations, Sections, 3D views

Then, click on a folder, let's say Plans. Now set the plan you want: the right layer combination, the right Display optons, the right scale. All well? Good - now the fat arrow again, Save current view. Save it, naming it as you would like its title on the layout to be (small habit that comes in handy in 8.1)

Proceed until you have all the views - meaning the drawings/images you eant in your layout book - defined.

For the 3D views, do them all. Then clone the folder, and open them one by one, redefining the output as Photorendering window - AFTER you set the photorendering options as you wish.

Don't forget to save.

Close ArchiCAD, open PlotMaker.
-am i importing one by one: Well for this excersize i am importing one by one on the "current layout". Only because i thought this would have gone easier on the system resources. I would however import the .pln and select everything i need. Is this the right way of doing it?

- You say i should be creating new layout options. this will plot each drawing to a separate page, am i right?. Will i then be able to have the plan and section in the same page? and rendered images?
When you open PlotMaker, set your Master (even better, create a template file and always start from it, saving it under a proper name for the project) and Import - find the PLN, find your view set, check all you want to import, and choose the option Append new layouts to layout book. Now you have a bunch of layouts, after the chugging is done, and you can arrange them as you like.

Let's not go into autotext, subsets, numbering, etc?

You can have whatever you want on the same page, provided it fits 😉 It is good to leave the machine chugging while you do something else, and then re-arrange the layouts and drawings.
-ok got that except your last point there. (open the pln in archicad 8 first?) before importing?

Nononono, you are short on memory anyway. Keep ArchiCAD closed - one is being open when you import anyway.
lets just say if all fails, ill attempt the export as .dwg and layout in ADT2004 which is not what i want to do!!!! {/quote]

Do this and you are out of this list
YOUR ON YOUR OWN!! but not anymore.
No, you are not
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen
Anonymous
Not applicable
"Only pressure can push the limtis, the music plays"

After that sleepless night, it looks like ive managed to solve all my problems well, archicad related ones!

publishing to ADT at 2:30am last night, the pictures was so simple yet detailed, led to enourmous memory usage! To lay out here was never going to work. Lets get that out of the picture

publishing to plotmaker!!!!!!!!!!!!!!!!!

now there is the answer. It seams to import that as if it was a 12kb jpeg. Its done instantly with no SISGL memory errors.

There seams to be a big difference from importing directly from my .pln rather than individual plk files. I know which way im going to do it. Still cant believe my computer cannot handle it im not happy about that. What was a carefully planed investment for a student turned out not to be as good as expected. out of money now! worth it though. Saving up for artlantis4.5

the next step?
Djordje
Ace
BryanRichards wrote:
publishing to plotmaker!!!!!!!!!!!!!!!!!

now there is the answer. It seams to import that as if it was a 12kb jpeg. Its done instantly with no SISGL memory errors.
That is another way to do it.

Anyway, you still need the views, hope that attached helps!
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen
Anonymous
Not applicable
yup, thanks!

crash course on AC8 complete! hehe, couldnt have done it without all that help.
Learn and get certified!