Installation & update
About program installation and update, hardware, operating systems, setup, etc.

3d perspective view suddenly goes blank

Anonymous
Not applicable
all,

HELP!!!

My 3d perspective view has suddenly gone completely blank. Ive checked my settings, all is good. The 3d axon works fine, and the 3d perspective even works fine on other workstations. So i know its not a problem with the file. It has to be a setting on my machine. Ive had issues in the past where ive accidentally pressed some hotkey and had to figure out what the hell i did, i figure the same must have happened here.

"Fit in Window" doesnt work, zoom in and out doesnt work. The scroll bars aren't even showing up ( they're shaded, not blue) on the side and bottom.

Im using Archicad 11 on a Mac OS (whatever the latest is). I can always go to someone elses workstation, but this is a serious problem for me. Ive found that having the 3d perspective on the second monitor is like a crutch for me now. Ive searched the forum, and it seems that someone else has had this issue, or at least similar, but no help for me. Any ideas?

Rayzor
13 REPLIES 13
Anonymous
Not applicable
Check 3D Cutaway, shortcut is apple Y so very easy to turn on accidentally. View > Elements in 3D View > 3D Cutaway
Anonymous
Not applicable
Thanks, but no luck. I had a thought last night, and tried to reapply my work environment thinking maybe it would undo whatever i did, but no luck there either.

thank though
Thomas Holm
Booster
Try the plan view in the Perspective Settings dialog. (It's size depends on the current zoom of the floor plan). Use it to change eyepoint and point of view.
AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1
Anonymous
Not applicable
help. help. help.

i have the same problem. did you work out what happened? i rebuilt it and now it has happed again. i'm desperate now. my assignment is due in 24 hrs and really need it.

jane
Chazz
Enthusiast
this has been covered in other threads and GS contacted me directly to send them a problem file so they could see what is going on. Unfortunately it became so problematic for us that we discontinued using Saved 3D views in layouts (you could do a search for our workaround) I suggest you contact GS directly and tell them you have a file that is exhibiting the issue for their study.
Nattering nabob of negativism
2023 MBP M2 Max 32GM. MaxOS-Current
Anonymous
Not applicable
What is the resolution to this problem/thread?
Stig Bengtsson
Participant
If one by mistake zooms far far away from the object, fit to window in perspective view has no effect. The 3d window becomes blank. In order to get back to a closer view go to the "3d projection settings" and reset the view, or go back to a saved view.

Stig
Architect AIA RIBA SAR/MSA, Graphisoft Registered Consultant
AC19 SWE 7006
AC20 SWE 4012
Anonymous
Not applicable
Here is what you need to do to get the 3D perspective view back:

Go to the plan view of your model

Go to View > 3D View Mode > 3D Projection Settings to edit the perspective settings (not parallel projections).

On the left of the window, you will see the plan of the model.

Press Alt on the keyboard and click to place target.
Press Shift on the keyboard and click on the plan to place the camera.
Try to place both on or close to the model plan.

On the right side of the window, where it says "Camera Z" and "Target Z", make sure the values are similar and positive.

If you go to 3D Generic Perspective now, you will hopefully see your model!

It worked for me
Anonymous
Not applicable
In the 3D OpenGL perspective view the model is cut by an invisible plane. Fit in window appears to shrink the model to a small dot. The bug does not occur while viewing the model in the axonometric mode or with the Internal 3D engine.

An ArchiCAD element's body includes a far-off point, which makes the model's bounding box very large. This far off point could be the result of an incorrect mitering of walls or a bogus setting of an element, e.g. unusually large light cone for a lamp, extreme stair height.

Solution

* Go to perspective OpenGL 3D window
*

Hit Fit In window - the model will “disappear” – it will move very far away from you
* Select all the window area with the arrow tool – you will probably see 2 or more distant selection dots
* If you select these points separately, you will probably see that one represents many elements, while the other marks only a single element (this is a bogus data element -- most likely a wall)
* Delete this element
* Save and close the file to clear the bad data from the memory
* Reopen the file
* 3D is now probably fixed (if not repeat above steps)
* Redraw the element(s) you deleted

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!