BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Installation on new 15 Mac Book Pro

Not applicable
Hi there,

I have problem installing from downloaded AC 17, but only on new one - MacBook Pro OS10.8, 2.7 GHz i7 ,my old 17' and Mac Pro are OK.

Installer quits shortly after require computer password typed in.

No problem installing and running AC 16.

Regards, Andy

I recommend that you run a Permissions Repair on your OS using Disk Utility and then try the installation again. I see that you are located within my support region so I will send you an email with step-by-step instructions.

Best regards,
Nicholas Cornia
Technical Support Team - GRAPHISOFT North America
ARCHICAD on Twitter
Not applicable
Thanks for email but did not work. I left message on 1-800 phone. Please call me back. It is anoying to have problem like this after more than 20 years working with software.
Regards, Andy
Karl Ottenstein

A few other things you can try. This seems to be an issue with something about your Mac configuration, rather than something on Graphisoft's end, even though weirdness with Macs is rare. On the other hand, since 16 did install for you... it's got to be frustrating!

First and easiest is to create another administrative user account, log out and log in as that new admin user and try again. Must be an administrator.

If that doesn't work, restart your Mac in Safe Mode, then restart normally and try again. Often Safe Mode clears out some lint.

Pushing the permissions repair to the extreme - download the free Onyx and after it performs the disk checks, let it do all of the defaults under 'Automation' to run maintenance scripts / system cleanup / permissions repair again. Reboot; try installing again.

I suspect a permissions problem, like Nick. Was your Macbook Pro a completely new installation - or did you migrate your user account and apps from another Mac? Did you change your user account name at any point?

Have you pulled up Console after the installer quits (assuming none of the above are successful)? Any log messages at the end of the "All Messages" view that give a hint for why things stopped?


PS Also, assuming above that you've run Software Update and your Mac is 100% up to date.
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.6, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Not applicable
Thanks Nick & Karl'

I had Graphisoft support over the phone and we did systematic 30min check of my new Mackbook settings and reinstalling the Java.... and at the end I was finally able to install.
I must tell that the level of 'self protection' at OS 10.8 is now matching windows one and the fact that Apple OS is much more more elegant (slick) makes it even harder to grasp proper setting,... anyhow it worked out, but to tell the true as why it worked at the end (my only suspicion was that Java was the culprit..) I do not know.
All this hustle didn't spoil my excitement about exploiting AC17 new features and I am looking forward to adopt those in new upcoming projects.

Once more, Graphisoft thanks for technical support.
Regards, Andy
Learn and get certified!