BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Really slow startup

Not applicable
O my new laptop ArchiCAD (v. 13-16 all of them) starts up really slow. Actually way slower than my old desktop – it takes 1,5 mins to get the splash screen showing. It's really slow considering that the laptop is a 2.6GHz quad core retina MacBookPro with 16GB RAM and a SSD.
Any ideas where to start looking?
Here's a caption from console – first row is printed a couple of seconds after the launch of the app and the last line is when you get the 'open…' window.

8.2.2013 8.40.28,805 ArchiCAD[41137]: [41137] Server connection update started ...
8.2.2013 8.40.28,898 ArchiCAD[41137]: [41137] 3Dconnexion framework not found!
8.2.2013 8.40.36,823 ArchiCAD[41137]: [41137] Server connection update finished ...
8.2.2013 8.41.15,357 mdworker[41150]: Unable to talk to lsboxd
8.2.2013 8.41.15,371 mdworker[41149]: Unable to talk to lsboxd
8.2.2013 8.41.15,000 kernel[0]: Sandbox: sandboxd(41151) deny mach-lookup
8.2.2013 8.41.15,423 sandboxd[41151]: ([41150]) mdworker(41150) deny mach-lookup
8.2.2013 8.41.15,428 sandboxd[41151]: ([41149]) mdworker(41149) deny mach-lookup
8.2.2013 8.41.49,684 GSQTServer[41156]: Create GSQTServer
8.2.2013 8.41.49,684 GSQTServer[41156]: Call InitServer
8.2.2013 8.41.49,685 GSQTServer[41156]: Call StartServer
8.2.2013 8.41.52,281 ArchiCAD[41137]: [41137] IFC_Common::CheckEnvironment()
8.2.2013 8.41.52,932 ArchiCAD[41137]: [41137] IFC_Common::RegisterInterface()
Not applicable
We are having exactly the same issue - did you ever resolve it. It appears to have happened here when our server was upgraded to SBS 2011. We have 8 PC's, and sporadically certain machines takes ages to load to the splash screen. Checked all the codemeter settings - nothing changes it!
Barry Kelly
I was going to say it could be your WIBU-key drivers searching all the ports for a WIBU-key.

But you say you have a Codemeter key.
I don't know if they might have similar settings - can't say as I don't have Codemeter.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Not applicable
Thanks - we already have the codemeter setting to look specifically for the IP address of the server its plugged into. However we had wibu keys when the problem first started and graphisoft technical couldnt work it out.

I think archicad must be searching for something over the network when it starts up, cant find it and times out - but it takes ages (5mins). If I knew what it was looking for we could make chages to server / firewall etc.
Not applicable
Just to add. We also note that after publishing out a series of PDF file using publisher, when we click 'close' archicad freezes up for 5mins.
Brad Elliott
This has started happening to me now. Frankly I don't remember when it started but it is much worse after a computer restart. I saw the note that Karl posted but I can't apply it to the Mac.
So I just quit and restarted the program and it takes 16 seconds to the splash screen and an additional 1:06 to get to the open window. As I said after a restart it is even longer. Any suggestions? I have included the start up log if that is of any use to anyone.
Mac OS12.6 AC26 USA Silicon
M1 Macbook Pro
Not applicable
Archicad 17 starting very slowly on Windows; starting ArchiCAD takes a long time

We had slow starting problems with ArchiCAD 17. It took a long time for ArchiCAD 17 to start. The problem was caused by JAVA runtime. After updating the JAVA runtime to a newer version the problems occurred. Reinstalling the correct JAVA version (the one included in the ArchiCAD package) the problems disappeared. For ArchiCAD 17 it means JAVA version 7u21.
You can check your JAVA version by opening JAVA under Programs in you Control Panel and then click about in the General tab.
You can find the correct JAVA for your ArchiCAD version here:
correct JAVA runtime for your ArchiCAD.
The problem with JAVA is that it complains about updates every day with an annoying popup. You can turn the Java(TM) Update Scheduler off in the startup tab in your Task Manager.
Brad Elliott
Thanks Wilt, that helps some. I had to do a reboot to get the old Java running but my times dropped some. About 3 seconds to the splash screen and 15 seconds to the open window. I'm not sure that that is enough savings to risk the ongoing Java security issue. I may go ahead and update and pretend it's the 90's when I open ArchiCAD
Mac OS12.6 AC26 USA Silicon
M1 Macbook Pro
Learn and get certified!