Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

ArchiCAD Custom Library Needs to be Reloaded Every Time a Project is Opened

Ruby9
Contributor

Currently our team has been experiencing the problem of needing to reload our custom library every time one of us opens a file that was saved by someone else/another computer, however when I open the file that I saved last the library does not need to be reloaded. The file path to the custom library folder never changes and shows the same correct path when we open the project, yet still shows missing library parts and needs to be reloaded. Is there any way to fix this issue? Has anyone else experienced this?

1 ACCEPTED SOLUTION
6 REPLIES 6
Karl Ottenstein
Moderator

I've seen this reported when the path is the "same" but some machines are Windows and some are Mac, since each OS has a different way of encoding the path.

 

By "reload" are you saying that Library Manager cannot find the library - as if it is not stored in the destination shown in Library Manager - and you have to browse to the custom library folder and add it to the loaded libraries every time a file is opened that was last saved by someone else?

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Yes, exactly that. We all use Windows 11, so I'm not sure why it would be any different. Our other libraries (ArchiCAD Library 26, ArchiCAD Migration Libraries, and MEP Library 26) all load fine, however these are located on the local C: drives on our computers, whereas our custom library is on a Z: drive. That seems to be the only difference, however it still seems like it should work if we never move the custom library folder.

Solution

Does switching from a mapped drive (Z) in Library Manager to using the full UNC server path work?  E.g., \\Server\Share\CompanyLibrary

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

That worked, thank you Karl!

Glad it worked!  But, I can't say I know why the mapped Z: drive didn't...  

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Mapping to a drive letter should work so long as each machine uses exactly the same drive mapping.

I prefer to use the actual full drive path as that can not go wrong.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!