cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.
SOLVED!

ArchiCAD Custom Library Needs to be Reloaded Every Time a Project is Opened

Ruby9
Contributor

Currently our team has been experiencing the problem of needing to reload our custom library every time one of us opens a file that was saved by someone else/another computer, however when I open the file that I saved last the library does not need to be reloaded. The file path to the custom library folder never changes and shows the same correct path when we open the project, yet still shows missing library parts and needs to be reloaded. Is there any way to fix this issue? Has anyone else experienced this?

1 ACCEPTED SOLUTION

Accepted Solutions
Solution

Does switching from a mapped drive (Z) in Library Manager to using the full UNC server path work?  E.g., \\Server\Share\CompanyLibrary

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

View solution in original post

9 REPLIES 9
Karl Ottenstein
Moderator

I've seen this reported when the path is the "same" but some machines are Windows and some are Mac, since each OS has a different way of encoding the path.

 

By "reload" are you saying that Library Manager cannot find the library - as if it is not stored in the destination shown in Library Manager - and you have to browse to the custom library folder and add it to the loaded libraries every time a file is opened that was last saved by someone else?

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Yes, exactly that. We all use Windows 11, so I'm not sure why it would be any different. Our other libraries (ArchiCAD Library 26, ArchiCAD Migration Libraries, and MEP Library 26) all load fine, however these are located on the local C: drives on our computers, whereas our custom library is on a Z: drive. That seems to be the only difference, however it still seems like it should work if we never move the custom library folder.

Solution

Does switching from a mapped drive (Z) in Library Manager to using the full UNC server path work?  E.g., \\Server\Share\CompanyLibrary

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

That worked, thank you Karl!

Glad it worked!  But, I can't say I know why the mapped Z: drive didn't...  

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Mapping to a drive letter should work so long as each machine uses exactly the same drive mapping.

I prefer to use the actual full drive path as that can not go wrong.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

@Karl Ottenstein Thanks for this reply. I am having the same issue with all files previous created on earlier versions of ArchiCAD. When I open older projects in AC27, migrate libraries, update the file etc the library objects (windows, doors etc.) from, say, AC26 or 25 do not load. I have to browse for the library via Library Manager and reload the older libraries. Once the updated file is saved, closed and re-opened the libraries go missing again....

I am on AC27 but use Mac with a mix of libraries on local drive and DropBox......if you have any thoughts?

NB: this has only happened with older files being updated to 27.

Thanks!!

g

 

I started learning ArchiCAD at age 50....bear with me,
AC26
MacBook Pro M1 Max.
Ventura 13.1

Could this have anything to do with mixing INT & USA libraries?

If you are using the USA language version, the migration will only work for that language as well.

If your file has used INT library for windows, they will be missing until you load those libraries.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi. @Barry Kelly  Thank you. This is possible. I've just not run into with earlier versions.

The 2 files that are losing the libraries were set up in Europe but supposedly using my NA/USA standards and libraries.

They are small projects so I am just working on updating all objects, mostly windows and doors, to 27.

 

Thanks.

I started learning ArchiCAD at age 50....bear with me,
AC26
MacBook Pro M1 Max.
Ventura 13.1