cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Help needed with Object Label 12

Anonymous
Not applicable
I use Object Label 12 to place information abour the size of Objects in plan, usually for cabinets and tables.
AC places it attached to the right upper corner at some strange distance from it!
I want to have it placed in the centre of the object.
Can anyone help?
11 REPLIES 11
rocorona
Booster
I get what you want, whit Italian library.
I only have to uncheck "use symbol's arrow" in the label parameters panel.

But ... checking more, it turned out that, if I rotate the object by 180°, the label does not detect this, and I get the same result shown in your image.

And, more over, the label is really centered ONLY if the placing hotspot (origin) is in the lower left corner.
_________________

--Roberto Corona--
www.archiradar.com
AC18 - ITA full on Win10
_________________
_________________
Anonymous
Not applicable
Thank you, Roberto!
I saw that with some objects the label appeared in the center, but couldn't fing why!
Alas, I walt to use the label exactly for objects with a center insertion point - lamps and switches!
Rob
Graphisoft
Graphisoft
Kliment,

your very first line in 2D script should be this:
IF label_custom_arrow THEN ADD2 label_position[2][1]+label_position[3][1]+symb_a_size/2,label_position[2][2]+label_position[3][2]+symb_b_size/2
::rk
Anonymous
Not applicable
Rob, I am afraid something is not working properly. Now the label goes to a certain position, but not in the center. The insertion piont of the object does not affect the positioning of the label.

I used Object Label 12 with your line of script inserted as the first line of the 2D script.

Please, see the attached picture:
labels 2.jpg
Rob
Graphisoft
Graphisoft
Kliment,

the problem is:
the label anchor is ALWAYS pointed to local zero of an object. So in your case the chair has the local zero in the left bottom corner (open the chair script as check the 2D full view).

So we have to move the label along X and Y by a half of the object's size each way (SYMB_A_SIZE/2 and SYMB_B_SIZE/2 respectively)

Now if you rotate this system it does not work because when rot. angle = 0; deltaX= SYMB_A_SIZE/2 and deltaY=SYMB_B_SIZE/2, however if rot.angle=90; deltaX=SYMB_B_SIZE/2 and deltaY=SYMB_A_SIZE/2.

in other words only if you had a lib part with centered 2D view it would work. I am pretty sure it could be resolved mathematically but it is not an easy task.

Does it make a sense?
::rk
Anonymous
Not applicable
Thank you, Rob! Everything is clear now! I'll have it in mind when I create new custom objects in the future!
vfrontiers
Enthusiast
I wonder if anyone else has noticed a change in AC12. Before, you could associate a label to an element, the label was on it's own layer and could be shown independent.

Now, even though a label is on an independent layer, it will NOT show unless the layer containing the ELEMENT that is is associated with is on.

Anyone?

Probably not a huge deal, but I had set up my layer combos to show only the clg ht tags (assoc. labels) without showing the ceilings they are assoc with for some structural base plans.
Duane

Visual Frontiers

AC25 :|: AC26 :|: AC27
:|: Enscape3.4:|:TwinMotion

DellXPS 4.7ghz i7:|: 8gb GPU 1070ti / Alienware M18 Laptop
David Shorter
Advisor
Duane, I have gone back to 10 and its just the same there. If the element is hidden the associated label will be hidden. As far as I know this has always been the case (sorry this is a bit of duplication)
Archicad 4.1 to 28 Tech Preview. Apple Silicon
you can't build a line
Mac Studio
iPad Pro
iPhone
vfrontiers
Enthusiast
Here's a new one...

Is there a GLOB_variable to tell whether the OPAQUE button is pushed in a LABEL?

Rather than the cheesy "add my fill" parameters, I'd like to tap into the existing setting dialog....

Anyone?
Duane

Visual Frontiers

AC25 :|: AC26 :|: AC27
:|: Enscape3.4:|:TwinMotion

DellXPS 4.7ghz i7:|: 8gb GPU 1070ti / Alienware M18 Laptop