Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Library Migration between ArchiCAD 16 & 18

Anonymous
Not applicable
Hi Everyone

I set up project templates using version 16 and am now on 18. I can open and edit with no issues, but every time I try to migrate the 16 library it doesn't work and windows/objects are missing... I end up having to load the 16 library on it's own.

I have followed the steps in the help section of the Graphisoft website but no dice.

This is time consuming and frustrating over the course of multiple files a day.

Any thoughts? Am I missing part of the migration process?

I'm on an iMac running ArchiCAD 18.

Thanks,
Amy
2 REPLIES 2
Are they rally missing? try selecting a "dot" and ctrl/cmd-T then Enter.
Sometimes the parameters may be set wrong and when migrating the object look like missing (especially when changing the language in-between).
Anyway there may be objects that migrate wrong...

BTW. Try not "migrate" the template but rather make new when stepping up from 16 upwards - import anything possible but try not using the old lib parts when using the 19...(the background processing relays on optimized objects and does not work if there are any objects not compatible -simplifying objects from AC 18 and before).
Anyway You have to do a big cleanup regarding the building materials etc - so the all composites must be more-less reworked.
I would start from the original template from 19, then imported layers and applied tools to them, then imported the composites and made cleanup to the attributes like fills etc. The last would be importing the favorites (in most cases they migrate ok with standard lib parts when imported)
The last move would be creating the views/clones and layouts (content may be copied - but afterwords you may have to do some additional cleanup in linetypes and fills atributes).

Best Regards,
Piotr
Barry Kelly
Moderator
I am no expert with this as I don't use the Graphisoft libraries.
But are you loading the 16 and 17 migration libraries (I believe you need both) as well as the full 18 library?

Barry.
One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!