Got a minute? We appreciate your feedback:

Graphisoft Learn survey
Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Strange error "0" related to libraries

Not applicable

we have a strange library problem on one of our office computers. The error occurs whenever a certain user wants to view an elevation of this one team project. (I'd suspect this occurs on sections and 3d view too, but can't confirm this yet, as this just happened and haven't had time to dig deep on his computer).

I've isolated this problem into our office std library. The library has recently been packed into .lcf-format, as I've understood that this format takes less space and loads faster. Other users have no problems using this newly .lcf-formatted library, but this one computer apparently has problems with the file.

This computer has the latest patch on both ArchiCAD.exe and the basic library. We are not using local "satellite" libraries.

I've quick/dirty patched this problem by replacing this users .lcf-library with the old, non-packed library folder, which seems to work fine for now.

Well, now here's the weirdest part: The presented error message in all its brevity is "0". (zero)

When an elevation is to be generated, ArchiCAD will go into this "0" -dialog box frenzy. Probably going through all the objects visible in this elevation and popping up a dialog box containing this mysterious "0"-message.

Does anyone know what this error message stands for?

I've got a couple of alternative solutions in mind, after quickly browsing through this forum.

1. I've run into some file permissions-based problems here, but they seem to be related to Mac-systems. We use a PC/XP Pro-system here. Maybe worth investigating anyways.

2. We could try sharing this project again, and hope that the problem goes away, and again hope that we won't run into it again in the future.

But for now, I'd appreciate an insight on this weird "0" -message box. Has anyone experienced this before?


I can now confirm that the error is generated in 3d view and sections too.

I found out that the problem only seems to relate to walls. The dialogs stop after hitting enter (for ~170 times) through the 'Processing walls(don't know the correct english term for this?)' -period of the elevation/section generation process. After that the elevation generation goes on to processing objects etc.., and does not throw any errors.

Another behaviour that seems odd is that after this finger-numbing enter hitting session is done, I can safely close the elevation, and generating it again won't give these "0" -errors. Other sections or elevations that have not been dealed with this process still give "0"-errors.

When I update libraries, the errors come back for the once dealed with elevations too.

And it does not seem like a TeamWork -related issue. I saved the .plc as .pln, and the problem persists.

Hmm... any ideas?

Thomas Holm
Samppa wrote:
...I've quick/dirty patched this problem by replacing this users .lcf-library with the old, non-packed library folder, which seems to work fine for now.
If that works, I'd leave it at that.

Otherwise, it's a lot of work to track down, is it in one or all projects, etc. And I'd reinstall both the library and Archicad, with patches. Could be a hard disk failure in coming, too.
Hmm... any ideas?
Or the dirty way... turn off "Interrupt with error messages" in your WE (see attached).
AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1

Not applicable
Thank you for your reply Thomas, didn't know that feature existed!

I managed to fix it.

The problem was not the lcf-format. The problem was old objects in the office std library.

We have in our office std library some old objects that came with this 'basic library' from our finnish reseller (Peruskirjasto, finns will know this). So i went through all these old objects replacing the office std library versions with the updated ones delivered with the ArchiCAD 11 version. And it works.

And that should've been the first thing to try anyways... It's kind of odd that on some machines the old object versions work flawlessly.

Well. It works now so everybody's happy!


And it doesn't have anything to do with lcf-format, really.

The version that worked 'unpacked' with this one machine was an older version of office std lib (I was previously a bit unclear about that). So the new office std lib contained some other erronous object/data, that wouldn't cooperate with one certain machine.

Thomas Holm
Samppa wrote:
The problem was not the lcf-format. The problem was old objects in the office std library.
And different libraries. So it goes.
AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!