cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

"Coordinate Dimension 25.gsm" showing wrong Project Origin coordinates

Hi again 😞

Used several coordinate dimension object and they are showing wrong coordinates when "Project Origin" option is selected.

User origin is set on 0,0 point. Grids and Backgrounds Rotation and other options also set to 0 values. Made Open & Repair - not helped. Cleaned up file, have no objects or meshes flying far from my project in 2D and 3D views.

 

Survey Point and Archicad "Move" tool showing project Origin coordinates correctly buy in Coordinate Objects they are shown wrong. What could cause such thing ?

AlgimantasKuprenas_0-1665642067666.png


AlgimantasKuprenas_1-1665642084460.png

 

For me it feels that objects are looking not into Real Project Origin 0,0 coordinate but in some Custom Project Origin coordinate that was adjusted somehow 😕

 

Very strange behaviour that when I have these coordinate objects in my big template file with many projects it's showing coordinates correctly. Total plan dimension size 500meter width 2000meter height.

AlgimantasKuprenas_0-1665645304440.png

 

But when I clean up file and leaving only single project that file coordinates it starts showing wrong Project Origin coordinates in Object. Somehow Project Origin that object is looking for is moved towards project from 0,0 point. If I would be programmer and can look into object source code I might tell what is the deal but unluckily all Archicad object have close source code 🙂

AlgimantasKuprenas_1-1665645849584.png

 



 

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33

11 REPLIES 11
Miha_M
Advisor

How do your Location Setting look like? Do the Easting, Northing show the same data as your Survey Point?

Miha_M_0-1665658275870.png

 

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

Looks like this:

AlgimantasKuprenas_0-1665660547724.png

 

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33

Looks like I found what causes this strange behaviour. Spend half of my day TESTING multiple cases with several files. If AC developers will be interested in this please contact me so I can show what actions causes this issue (BUG). Looks like I'am starting to be Software TESTER :), not an CAD Engineer 🙂

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33

Miha_M
Advisor

Using this Coordinate Dimensions element you should get the relative distance from the 0,0 Archicad coordinates, so this is strange. What happens if you use the Survey Coordinate Library Object? Does it give you correct values?

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

When I place Survey Point onto 0,0 and use Survey Coordinate option, coordinates are ok, but we cannot use this method because when architects adjusts Rotation of North it starts to show strange coordinates again because survey point gets rotated with whole Survey point coordinate system.

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33

Miha_M
Advisor

I would suggest you to use the survey point tool and the related workflow. This way you don't need to adjust anything during the project. And this way you'll always get the correct location reading (and model placing, if you share your model via IFC).

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

I would use Survey Point option but as I told, when you adjust North direction, survey points North direction also changes and it rotates whole coordinate system and gives wrong coordinates again. Survey Point solution work only when North direction is rotated 90 degrees in project information table. Because we do use North rotation we cannot use Survey Point coordinates 😞

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33

Could you share your solution, We have same issue too. 

No solution yet, GS need to release update for this to be fixed.

GRAPHISOFT BIM Manager Training Week attendee
ArchiCAD v9 - v26 INT / NOR (5002)
cpu i5-12600K @ 5.0Ghz, ram 32GB, gpu 1060 GTX
ssd NVMe, Windows 11
ArchiCAD Discord channel: https://discord.gg/QdWxSJ33