cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

Apple M1 Units - I select items and they always want to move

Roderick Anderson
Contributor

Has anybody noticed this also and found a way to make this behaviour go away?

 

I select any element (either on plan or 3D view) and if I don't wait for 1-2 seconds after selecting the item, the element will always think I want to move it.  Therefore, if I am trying to work quickly and just select the item and then move the mouse over the the Info Box to edit any settings, the settings will be grayed out because the element is in the middle of a move command !

 

I've been using Archicad since version 10 and this has now been happening on version 26 and 27, but only if I use any of my Apple M1-equipped Macs.   I use a MacBook Pro and a Mac Studio, both of them with the Apple M1 Max chip and they both behave the same.

 

Does anyone think of any possible setting in the Work Environment that could help with eliminating this behaviour?  It gets kind of tiring trying to quickly select items, but having to wait a couple seconds after selecting a wall, a slab, an object, etc., because if I don't wait then it'll think I want to move the objects.

AC8.1 - AC27 ARM SPA + CI Tools
Apple MacBook Pro M3 Max Chip 16C CPU/ 40C GPU
64GB RAM OS Sonoma 14.3
20 REPLIES 20
mthd
Ace

That is strange and you have tried two different Mac devices and you are still getting the same problem. When troubleshooting were you using the same mouse on both devices when testing ? Keep trying different things and make sure your mouse is fully charged. 

AC8.1 - AC27 ARM AUS + CI Tools
Apple Mac Studio M1 Max Chip 10C CPU
24C GPU 7.8TF 32GB RAM OS Ventura
Scraptrash
Booster

I have this problem too since the release of AC26. Finally someone asks. Thanks. 

I’m using M1 MacBook Pro and AC26. I think this is an obvious bug. 

It happens even when I don’t connect my mouse, just using the built-in trackpad. 

I can’t find any way to work around this bug. 

MacBook Pro (16 inch, 2021) Apple M1 Max 64GB macOS Monterey Archicad 26 MBP trackpad Logitech Master MX3
furtonb
Advisor

M1 Max MBP here, same behaviour - really annoying.

odv.hu | actively using: AC25-27 INT | Rhino6-8 | macOS @ apple silicon / win10 x64

The mouse is not the problem.  It happens independently if I use:

  • The Apple Magic Mouse
  • Logitech MX Master 3S mouse
  • Logitech MX Anywhere 3S mouse
  • The MacBook's trackpad

I just got my new Apple M3 Max unit today, in the process of installing everything, so I'll report in the event this does not happen with the M3 Max chip and is something only related to M1 Max.

AC8.1 - AC27 ARM SPA + CI Tools
Apple MacBook Pro M3 Max Chip 16C CPU/ 40C GPU
64GB RAM OS Sonoma 14.3
mthd
Ace

I am not having this problem. My M1 Mac was purchased in Australia at the end of 2022, I haven’t upgraded to Sonoma yet either. Would be good to hear if the M3 is any different ?

AC8.1 - AC27 ARM AUS + CI Tools
Apple Mac Studio M1 Max Chip 10C CPU
24C GPU 7.8TF 32GB RAM OS Ventura
Lingwisyer
Guru

Is there any delay between when you select an entity and it highlighting?

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660

@Roderick Anderson wrote:

The mouse is not the problem.  It happens independently if I use:

  • The Apple Magic Mouse
  • Logitech MX Master 3S mouse
  • Logitech MX Anywhere 3S mouse
  • The MacBook's trackpad

i use Logitech MX master & MBP trackpad. Same buggy behaviour

MacBook Pro (16 inch, 2021) Apple M1 Max 64GB macOS Monterey Archicad 26 MBP trackpad Logitech Master MX3

You could say there is a slight reply.  When you select an element it kind of flashes a couple of times and after this it is selected.  If you move the mouse (even if ever so slightly) during this flashing of the selection then it thinks you want to move (drag) the element.

I was paying closer attention to this on Friday, and it seems to me the behaviour does not happen all the time.  I opened up AC27 and started working on a project and noticed "hey the problem is not happening" and then after a while it started happening, and then from that point forward it kept on happening.  So it seems there is an action at some point that does trigger the behaviour.

I have completed setting up my M3 Max unit and will start working on a project on it tomorrow, so I'll report back if this also happens with that processor.

Roderick Anderson
SARCO Architects Costa Rica
Archicad 25 SPA
2022 Mac Studio M1 Max - Apple Studio Display - OSX 12.51 (latest)

Just found, same behavior even when I only use remote desktop (Jump desktop) to control my computer and archicad. It’s obviously not related to any physical input device.

 

How can we raise this as a bug to GRAPHISOFT?

MacBook Pro (16 inch, 2021) Apple M1 Max 64GB macOS Monterey Archicad 26 MBP trackpad Logitech Master MX3