cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics Cards Issues and Troubleshooting

Haris Matthaiou
Graphisoft
Graphisoft

Cross platform issues

Archicad crashes with integrated Intel HD4600 graphics card on UHD monitor resolutions

 

Issuewp-content_uploads_2018_07_intel_HD_GPU_100px.jpg
Archicad may crash at some point while working on integrated Intel HD4600 graphics card with UHD resolutions.
 
Cause
The crash may either occur due to limited graphics card memory size (VRAM) or because of Intel's limited texture memory size (L3 cache) on Archicad's window size.
 
Workaround
In an attempt to reduce the allocated VRAM for Archicad, we may disable both 2D  Drawing Antialiasing and 3D OpenGL Antialiasing by browsing to Options > Work Environment > Advanced Redraw Options and unchecking these options. That would decrease the allocated VRAM and possibly prevent further crashes by sacrificing some quality in visual representation. Since there are no ways to reduce the texture memory size, avoid spanning Archicad  main window into multiple monitors. If crashes continue to occur on single monitor setup, reduce Archicad's main window size. Intel HD4600 graphics card is not really recommended for Archicad usage -especially in UHD resolutions.

Windows OS specific

Archicad crashes on laptops with dual graphics cards (multiple GPU's)

wp-content_uploads_2018_07_amd-dual-graphics-100px.png wp-content_uploads_2018_07_NVIDIA_Optimus_100px.jpg
 
 
 
 
 
Issue
Users with Windows laptops running dual graphics processors (GPU) by implementing Optimus (Nvidia) and Enduro (AMD) technology, experience startup crashes with Archicad.
 
Cause
Belated switch between the integrated and the discreet graphic card causes Archicad to crash on Windows.
 
Workaround
For Nvidia Optimus, use this PDF guide for selecting power saving option for Archicad.exe by setting it to “High-performance NVIDIA processor” profile. (page 17 at the PDF file) For AMD Enduro, use this PDF guide for selecting power saving option for Archicad.exe by setting it to “High Performance” profile. (page 2 at the PDF file).
 
wp-content_uploads_2016_06_Info_18x18.png NOTE: AMD hardcoded "High Performance" profile for Archicad process with their 19.xx driver series, so no manual selection should be required with latest AMD drivers.

macOS specific

Antialiasing disabled on macOS 10.11 - 10.12 with Archicad 22

 

Issue
Users with MacBook Pro laptops implementing dual graphics processors (GPU) experience that the 2D and 3D Antialiasing feature is turned off by the system and cannot be turned back on.
 
Cause
Apple's macOS 10.11 and 10.12 tries to use too much memory with Archicad 22 on MacBooks with an external 4K/5K screen. GRAPHISOFT runs Archicad 22 without Antialiasing to avoid overusing the GPU memory resources and causing a crash.
 
Solution
GRAPHISOFT fixes this error in the first Update (Build 40XX) for Archicad 22. For the fix to take effect, the OS needs to be migrated to 10.13 (High Sierra) after installing the update.

Archicad 22 crashes on MacBook Pro with dual graphic cards (multiple GPU's)

 
Issue
Users with MacBook Pro laptops implementing dual graphics processors (GPU) experience startup crashes with Archicad.MacBook Pro.jpg
 
Cause
Belated switch between the integrated and the discreet graphic card causes Archicad to crash on macOS.
 
Workaround
Close Archicad, download and run third party application gfxCardStatus . Switch to the integrated (Intel) graphics card  and launch Archicad . No crash should take place. Close Archicad, switch to discreet graphics card and launch Archicad again.
 
Solution
GRAPHISOFT fixes this error in the first Update (Build 40XX) for Archicad 22.

Archicad crashes on iMAC desktops with Retina displays

 
Issue
iMAC desktops with limited graphics card memory (VRAM) of 512 MB running on Retina displays, can at some point cause Archicad to crash.
 
CauseiMac.jpg
There is a direct relation between the allocated graphic card memory (VRAM) and the display resolution. Retina displays run on high resolution thus the allocated VRAM is proportionally high as well. When Archicad runs on graphics cards with less than 1 GB of VRAM , it may exhaust the available VRAM and ultimately crash due to insufficient resources.
 
Workaround
In an attempt to reduce the allocated VRAM for Archicad, we may disable both 2D  Drawing Antialiasing and 3D OpenGL Antialiasing by browsing to Options > Work Environment > Advanced Redraw Options and unchecking these options. That would decrease the allocated VRAM and possibly prevent further crashes by sacrificing some quality in visual representation.

Archicad freezes with Parallels Desktop

 
Issuewp-content_uploads_2018_07_parallels.100px.png
On Parallels Desktop in Windows host, Archicad is not responding without turning Parallels into suspension mode.
 
Cause 

Parallels Desktop 13 is using outdated DirectX 10.1 version which deems the implemented Parallels driver defective for Archicad usage.

 
Workaround
For OpenGL, we can skip this version and switch over to macOS Quartz implementation along with Archicad internal Engine: Open registry editor (search for “regedit.exe”) and navigate to “Computer/HKEY_CURRENT_USER/Software/GRAPHISOFT/Archicad-64/Archicad-64 22.0.0 XXX R1/Graphix”. Right-click on “EnableHwAcceleration” to modify the DWORD value from “1” to “0”.

Archicad crashes on OpenGL with AMD FirePro M4000

wp-content_uploads_2018_08_m4000.jpeg
Issue
In rare cases where AMD FirePro M4000 GPU wakes up from sleep/standby, Archicad might crash on OpenGL function.
 
Cause
The source of the problem is at driver level after wake-up post initialization and it is not caused by Archicad
 
Workaround
Unfortunately, the GPU has reached End Of Life support so there will be no fix from vendor and no workaround is possible.

OpenGL 3D window shows a blank screen with Archicad 21 and Radeon RX580

 
Issuewp-content_uploads_2018_08_AMDPolaris-580x358-150x150.jpg
With driver Adrenalin 2019 Edition 18.12.2 and onwards, 3D Window does not display any content.
 
Cause
There seems to be a regression issue with the latest drivers and OpenGL variant (compatibility profile) that triggers this annoying behavior.
 
Workaround
Revert Adrenalin driver to an older version. Previous version drivers can be found here. Adrenalin Edition 18.11.1 should work properly with Archicad 21.

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!