cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Teamwork & BIMcloud
About Teamwork, BIMcloud, BIMcloud Basic, BIMcloud Software as a Service, network settings, etc.

Remote Teamwork connectivity + multi session freeze (solved)

Paul King
Mentor
I recently found that if BIM server was trying to manage two concurrent client sessions, whether connections were via same local network or via remote network, or one from each, that the second session simply would not communicate with BIMserver.

The projects could be very simple - can contain only one or 2 elements, but attempting to reserve anything on the 2nd session project, I would need to wait literally overnight before the action completed.

Checking Task Manager on the BIMserver host PC and the client PC, network & CPU activity sit on around 0% even while the 2nd session of ArchiCAD showed a 'busy' mouse pointer.

The first session of ArchiCAD could work and send and receive normally throughout, even while the 2nd session was effectively left waiting indefinitely.

Beyond this, I also experienced disconnects for my remote user at random intervals anywhere from a few hours to a day or two apart, where BIM server manager connectivity checker confirmed connectivity was lost. This kept happening even though there had been no user initiated changes to network or BIMserver settings between the working state and non working state.

BIMserver is on wired Gigabit network connection to router. Router has fixed IP address and this same address is used for all local and remote client connections. BIMserver & remote client connected via reasonably fast VDSL connection

I found solutions eventually - see next post below.
PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop
3 REPLIES 3
Paul King
Mentor
Problems solved.

The slowdown/infinite waiting issue for 2nd connection was very likely a permissions error or other corruption within windows 10 on the server machine - even though it was a near fresh install of windows.
Problem went away after I ran the Tweaking.com Windows Repair tool v 3.9.2 using the recommended procedure.

That said, everything worked perfectly until a couple of days later when the BIMserver stopped accepting remote connections on ports 19000 and 19001, even though router port forwarding and server/Windows firewall and network settings had all been left entirely unchanged from when they were working.

A lot of research and trial and error later, I found by chance that simply toggling Windows firewall off then back on cleared the problem - though only for a few more hours or days.

I was lucky enough to receive the suggestion from a networking guru that not only do the ports need to be open in Windows Firewall, but the app using them needs to be added to the trusted apps list.
I added BimserverManager.exe to the trusted list and so far no further problems.

In case it helps others, below are a range of things to check if experiencing similar port forwarding / remote connection issues:


Remote BIMserver connection troubleshooting checklist

Check the following:

  • 1/ Your ISP has given you a fixed external IP for your router and this is what the server is actually connecting through - check with http://www.pcwintech.com/myip

    2/ There is only one port forwarding rule set up on the router for the required range - i.e. no conflicts. There is a free port forwarding setup tool which may help if your router is supported - http://www.simpleportforwarding.com/

    3/ Port forwarding does work to the server with current router settings (run PCWintech port tester - http://www.pcwintech.com/simple-port-tester from the server, while BIMserver is not also running)

    If not, as a test check whether it works to another computer on another fixed IP address on local network - for the same or a different port range (router NAT port range and destination settings to be changed accordingly, but remember to undo the changes after the test)

    4/ Even if port forwarding appears to be working when tested by a 3rd party port tester, I have observed that if multiple port ranges are forwarded to the server local ip address (including just for multiple BIMserver module versions) BimServer Manager inexplicably reports that all but the most recent module cannot connect. Eliminating all rules for all ranges but one seems to work in this case, though this is less than desirable as a workaround for obvious reasons. This does not seem to be a router or port range/rule conflict issue (if third party port tester is correct), but may be a windows issue? To get all modules working you may need to nominate a single rule with a longer continuous port range that all modules and other apps can share, ensuring within app settings that each app / module uses own unique ports within that range. A single rule containing more than one port range does not seem to help - it seems that all ports forwarded to the server must be within a single continuous range. A weird one.

    5/ There is only one router between the server PC and the internet, as verified with the PCWintach 'Detect Multiple Routers' tool. Port forwarding needs to be set up on all routers in order for connections to get through

    6/ Server has plenty of free ram & SSD HD space & good Broadband upload speed in particular.

    7/ The server PC is indeed always on the nominated local network IP address, and is running 24/7 - not going into standby

    8/ Server PC network card has power management disabled, so should be always on & not reliant on wake on LAN capability

    9/ The router DHCP allocation range has been set with range outside the fixed local IP address given to server PC. E.g. set server PC fixed local network IP to 192.168.0.10, and router DHCP range from 192.168.0.100 to 192.168.0.255

    10/ If remote ArchiCAD user can access BIMserver, but local network user cannot via the same external address, your router may not support reverse NAT. Secondary local network path addresses should be added in BIMserver manager. Having different BIMserver address between local and remote users should no longer adversely impact BIMserver hosted library paths for ArchiCAD 19 and up, though is a problem for AC18 and below

    11/ Ensure any fire walls on the server PC have an exception set up for the forwarded port range. Try turning firewalls off as a test. Some routers also have firewalls - if enabled these also need exceptions to be set up IN ADDITION to the port forwarding you set up on router. You probably don't need your router firewall enabled in addition to local PC firewalls (unless you are a large company that attracts lots of DoS attacks), as the router NAT already gives pretty good protection from most things, unless you foolishly leave it in 'DMZ' aka unprotected mode (don't do that - it wont help as NAT needs to be enabled for port forwarding to work anyway)

    12/ Ensure there are no windows firewall problems, other firewalls or remnants of firewalls detected by the PCWintech 'Repair WMI & Windows Firewall' and 'detect possible firewalls' tools.

    13/ That toggling your windows firewall off then back on does not help

    14/ That BimserverManager.exe is added to the trusted applications list in Windows Firewall. Just opening the required ports in the firwall seems to be insufficient and can result in random disconnects every day or 2

    15/ If BIMserver is for a small number of users and so running on an ordinary windows PC rather than on windows server operating system version, try the Tweaking.com 'Windows Repair tool' v3.9.2 using the author's recommended procedure - this cleans up lots of obscure registry and administrator permissions issues, identifies corrupted operating system files etc that could all have an impact, even if you have just recently done a clean install of windows

    16/ If all above fails to achieve and sustain a solid long-term connection, there is a good chance you have a flakey router - probably time to bite the bullet and buy a new one
Hope this helps somebody.
PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop
Anonymous
Not applicable
I've had this problem too VPN can cause problems 192-168-0-1ip 192-168-1-1login
SeRohde
Booster
Thank you for this insight. Good Read.

I was stumbling upon the Term reverse NAT. Here is an explanation from the same source:
http://www.pcwintech.com/test-for-reverse-nat

Keep in mind that some router/firewall/utm vendors maybe use a different name for this, since reverse NAT isn't a standard term (afaik).
Admin of BIM [Cloud] [SaaS] [Server] | AC 19-25 [Win&Mac Clients] | VM's