Teamwork & BIMcloud
About Teamwork, BIMcloud, BIMcloud Basic, BIMcloud Software as a Service, network settings, etc.

VPN-server for BimCloud in office, connect from home

Not applicable
We have bought a licensed Archicad (but it looks like we don't need full version of Bimcloud, basic is probably enough for us).

Problem is I am not a technical specialist. I need to install a server for Archicad.

So I 've installed Archicad and BIMCould server (+manager). Now I have access to it from http://localhost:22000
OK, I've activated basic server. ok, added a few users. OK.

Then I've installed Archicad on another pc (laptop). I use it both at home and in office.

On server I made support for incoming VPN connection. Local IP address within office network is something like

So from my laptop I try to connect to VPN, use as IP address of server, do login+password. OK, connect successful. But note: it only withing same wifi network in office.

So, I logged in into archicad as teamwork user, set as server, so I can now work in "team work". fine.

Next, I need to same on my home pc, my laptop. So I connect in office through another ISP (internet service provider), and set IP of our router as IP address of server, to which I have to connect.

But it looks like we don't have static IP for server, and my friend said: "it is not necessary!"

So, I though, how to connect to our archicad server from home laptop?

I've registered on site
there I received a free domain like ""

but it is linked to ip address of a router. thus, when I enter this address "" into a setting of a new vpn-connection on my laptop, I get an error #691...

So, how to make this all work?

Do I need to access a router's settings to make this work? I suspect - yes. By my friend, administrator says: it's not necessary. So why? (he is "upper admin" above me here in office).

what to do, how to make all this work?

(thanks in advance)
Noemi Balogh
Community Admin
Community Admin
Hi UgraNrisimhaDas,

The error code you mentioned is coming from your VPN - possibly not even the VPN connection can be established properly.

Some points I would mention to check:

1. You mentioned that you set your router's IP as the address of your VPN connection. This means, that your laptop can connect to the router, but still can't find the server machine.

In this case, you must set port forwarding, so the VPN connection can found the proper machine behind the address. This is strongly depending on the devices and software you use, so I would suggest to ask for help from someone who is familiar with it, or try to search for the products for further instructions.

2. Using a dynamic IP for BIMcloud Basic is possible, however, we really don't recommend to do that.

The reason is that both the components of the BIMcloud, and ARCHICAD are constantly using the address to communicate with each other. In case your IP is changed, these components and ARCHICAD clients can no longer connect.

3. Using a free option, such as is a possible solution, but don't forget that these free licensed programs has some limitations, which can cause further trouble (see my second point).

Kind regards,

Noémi Balogh

Community Expert, Admin

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!