Choose your top Archicad wishes!

Read more
Archicad C++ API
About Archicad add-on development using the C++ API.

Updating Add-ons from 8.1 to 9

TomWaltz
Participant
I am trying to update an add-on I wrote for 8.1 to run on Archicad 9 on macOS 10.3.

I opened the file in Codewarrior, repointed all the support directories to the DevKit 6.1, and recompiled.

Archicad 9 tells me the add-on is outdated and will not run.

Is there a step I'm missing? Or a FAQ on this topic?

Thanks!
Tom Waltz
4 REPLIES 4
Karl Ottenstein
Moderator
Just a guess, Tom: did you do a complete rebuild? It's possible that some old compiled resource or object files were used in the link since an ordinary 'make' wouldn't have found them out of date.

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
TomWaltz
Participant
Yeah, I did. I had thought of that as well.
Tom Waltz
TomWaltz
Participant
Whoops! Not complete enough of a rebuild!

It works!
Tom Waltz
Karl Ottenstein
Moderator
TomWaltz wrote:
It works!
Hurray!

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB