cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

BIMx
About BIMx (mobile, web and desktop), connection to BIMcloud, and related technical questions.

BIMx supports Google Cardboard VR on smartphones

Laszlo Nagy
Community Admin
Community Admin
Today a new update was released for BIMx.
The biggest enhancement is support for Google Cardboard VR on smartphones (not on tablets at this point).
You can simply update your BIMx on your smartphone to get the latest functionality.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
42 REPLIES 42
Stig Bengtsson
Participant
Is there a file size limit for Cardboard VR?

I added GI to a BIMx model and the file doubled in size but I can still open it on my phone. I just don't get the three dots where I can choose Cardboard.

Stig
Architect AIA RIBA SAR/MSA, Graphisoft Registered Consultant
AC19 SWE 7006
AC20 SWE 4012
The default model works great, but when I try to run a model thats 120 mbytes or 158 then cardboard view just freezes. eventually it loads but still doesnt perform like the default model.
Hans Roest
Booster
Same here.

Default model works fine, this is exactly what we have been waiting for!

Whenever I upload a BIMx hypermodel of my own and enter the VR mode the dual viewports just freeze up. It works for one second, and then freezes. I have tried serveral methods to get my own models to work:
- Large models with / without GI;
- Small (even just a single slab) with / without GI;
- Create BIMx from AC20 and uploaded tot BIMx online portal;
- Create BIMx from AC19;

Nothing seems to matter, nothing works like the demo model.

When I tap very fast for serveral times the viewports start to work again (after some waiting).
However, after I single tap (to bring up the menu), the viewports freeze up again. Single tapping closes the menu and starts the walking again. This leaves me with:
- VR mode works, but after a long wait in the beginning and after A LOT of fast taps on the screen to get it to work;
- Basicly only walking mode, when I single tap to bring up the menu / look around, the views freeze.

This feature is super-exiting, hope to get it working better soon!
Sucks because it seems to be model-related (demo model works). Any help here?

Specs:
- ArchiCAD 20, build 4009 (NED FULL);
- Android 6.0.1;
- Samsung Galaxy S6 Edge + Gear VR (in Cardboard mode);
Hans Roest
Booster
Hans wrote:
Blablabla (my earlier post)
BIMx Hypermodel from ArchiCAD19 works like a charme (normal models don't). Models from AC20 keeps having the same problem.
This feature rocks!!
DGSketcher
Legend
Have you installed the latest version, I thought we were on AC20 build 4012 but I dont have access to check today.
Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)
Hans Roest
Booster
DGSketcher wrote:
Have you installed the latest version, I thought we were on AC20 build 4012 but I dont have access to check today.
Build 4009 is the latest for Windows, 4012 is Mac only?
DGSketcher
Legend
You are correct. I thought the build numbers for win & Mac were synced.
Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)
Stig Bengtsson
Participant
Yes, now I realize the model has to be published as a Hyper model. Just saving as BIMx from the 3D-window doesn't work with Cardboard.

Stig
Architect AIA RIBA SAR/MSA, Graphisoft Registered Consultant
AC19 SWE 7006
AC20 SWE 4012
it seems to be hit and miss with my models. maybe its based on a polygon count. i have a project that when i just publish the 3d model its ends up and 38 mbytes, it is a large very detailed house with furniture and all. it does not load in cardboard mode.

i have another model that is a lot less complex, and with the 2d docs ends up being 39 mbytes. it opens and runs every time perfectly.



edit: I can confirm that file size and polygon count play no role in my models working in cardboard mode. as well as whether or not GI is involved.

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!