Choose your top Archicad wishes!

Read more
Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Archicad model does not appear in twinmotion after importing it


Hi, does anyone know how to solve this problem?


I tried importing the Archicad file into twinmotion via datasmith file and also directly synchronizing with direct link, but the model does not appear after importing it. There is a layer of the file that appears with the materials, but no matter how much i zoom in or try to scale it up, nothing is there. I also tried importing it with different export settings in Archicad, but nothing seems to work... I also tried saving it as Wavefront file and when I look at the file on my desktop, you can see the structure, but once I import it, again, there is nothing there. I have never had this problem before and I am going crazy, trying to figure what I am doing wrong.


If someone knows how to solve this, please help me.


Im attaching screenshots of twinmotion after importing it, a Wavefront file on my desktop and an Archicad screenshot.

Laszlo Nagy
Community Admin
Community Admin

As the Archicad -Twinmotion Connection is developed by Epic Games, it may be more productive to raise this issue on their forum, you will probably get help on this issue sooner:

Loving Archicad since 1995 - Find Archicad Tips at
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Barry Kelly

I think it might just be that it is not in the default Twinmotion viewing area.

I am sure there is a way to do something like a zoom to model, but I don't use it enough to remember the exact command.



One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Okay, thank you! I will write there, maybe they will understand the issue better. 😊 


But I think it has something to do with visibility in Archicad... I merged 2 files in Archicad and the one I am trying to import in twinmotion (the screenshot one)  is also invisible in Archicad 3d perspective of the merged Archicad files, even though, in plan there are walls, slabs... ( and all the layers are turned on.)


Do you maybe know what I am doing wrong in Archicad that it is also invisible in 3d? 

Laszlo Nagy
Community Admin
Community Admin

There are many things that can cause elements to be not visible in 3D, check this thread:

Loving Archicad since 1995 - Find Archicad Tips at
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27

Hi @MASAM I have the same problem!


Did you find a solution?

Mac OSX 13.6.6 | AC 27 INT 5003 FULL

I´ve the same problem and I don´t have any ideas to fix it...


Last week I worked with Twinmotion and i saw every single object / element, but now I can´t see any elements in Twinmotion after import from ArchiCAD...


Edit: Twinmotion only import lights, if some are placed in ArchiCAD

Bea Moreno

Same problem here.

Please let us know if you found a solution. 


Karl Ottenstein

This is an old thread, but has a new and new-ish replies.  To the OP and recent posters - you really need to include in your posts all of your software details - or include it in your signature as you can see several of us here doing.  The OS, version of TwinMotion, version of your Datasmith plug-in, Intel vs Apple Silicon etc all matter for someone to reproduce and either confirm the issue or work with you to resolve it.


I have no problems at all.


I'm running AC 26 USA Build 5003 on macOS Ventura 13.4 on an Apple Silicon M2 machine running the Apple Silicon version of Archicad.


I'm running Twinmotion 2023.1.1 with the most recent Datasmith plugins dated March 14, 2023 downloaded from here:


With AC 26 and TwinMotion both running and the datasmith palette displayed in the Archicad 3D window, I click Import in Twinmotion to create a new link to Archicad, I click the refresh button on the datasmith palette in Archicad and the model is transferred.  NOTE:  there is no zoom to your model!  It could be anywhere in space, and potentially not even visible.  In the model browser in Twinmotion, the easiest way to find your model is to select an element, right click, and zoom to that element.  Then navigate back out to where you want to be.


Hope that helps!


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

I am new to Twinmotion (just started today) and was experiencing the same problem. 

I realized that I didn't do all the necessary steps to import/sync the Archicad model and Twinmotion, this video helped me: