Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Export to Excel with "European" digit grouping

Not applicable
There seems to be (and always has been as long as I remember) something wrong with the way Archicad exports its large digit numbers with "European" style "digit grouping symbol" in Windows. That is numbers in format "123 456 789". When such number is exported, the Excel thinks that the thousands separator is a "space bar" and does not consider such numeric value as a number.

But what is worse, it is not really a space bar, because it is not even selectable by the find and select command in Excel. The fact that it is not a space bar shows also at some more "exotic" fonts when working in Archicad, where it is replaced by some weird symbol.

A working workaround I found out to be, is to replace the default Windows digit grouping symbol by manually typing a " " (the real space bar) in the digit grouping symbol field in the regional options. With such manually defined thousands separator, the excel is able to recognize numerical values exported from Archicad correctly.

Or has anyone already tried this and it led to any other problems?

Seems to be a problem similar to this one:

Daniel Kovacs
Graphisoft Alumni
Graphisoft Alumni
Hi mbl,

It seems like if you export an XLS or XLSX with 'Save as...', You should not have this issue. I found this happens only when I use the "Export Property Values from Schedule" option (although your experience may vary, since you are on Windows 7 not Windows 10, so that might work differently).

Anyhow, the reason you can't 'Find & Replace' the character with Excel, is that it is not actually a Space character. It is a Non-Breaking Space (nbsp). This is a special character that looks like a space, but doesn't let characters separated by it break into separate lines, so 1 000 000 at the end of a line would not break into something like this in word:
1 000

I let the developers know about this issue, and they are looking into it (task #264910 in our system). What you can do though, is either:
  • change the separator character to an actual space (like you did), or you can also use a comma/point as a separator (I don't know if your local standards allow for it, but where I live, we can use spaces or points as separators, and for decimals we use commas)
  • or you can use Find & Replace in Excel and search for the nbsp character instead of a space character to delete them all at once (see the wikipedia article about how to type that character).
I hope this info will be useful for you.

Daniel Alexander Kovacs

Professional Services Consultant


For Troubleshooting and useful Tips & Tricks visit

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!